No wifi adapter driver on kernel 5.4

I’ve recently tried to switch to kernel 5.4 in order to solve problems I have with my gpu on newer kernels but for some reason I can’t use wifi.
inxi --admin --verbosity=7 --filter --width

System:
  Kernel: 5.4.169-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
    root=UUID=584e4a68-ed04-42c2-892d-f3f6f50f3761 rw quiet apparmor=1
    security=apparmor resume=UUID=a4a9ed97-abcd-4b36-bb0b-1e236d350a31
    udev.log_priority=3 radeon.runpm=0
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Laptop 15-bw0xx v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8331 v: 27.35 serial: <superuser required> UEFI: Insyde
    v: F.52 date: 12/03/2019
Memory:
  RAM: total: 7.25 GiB used: 922.8 MiB (12.4%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD A9-9420 RADEON R5 5 COMPUTE CORES 2C+3G bits: 64 type: MCP
    arch: Excavator family: 0x15 (21) model-id: 0x70 (112) stepping: 0
    microcode: 0x6006705
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 192 KiB
    desc: d-2x32 KiB; i-2x64 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 1979 high: 2051 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2051 2: 1908
    bogomips: 11982
  Flags: 3dnowprefetch abm acc_power aes aperfmperf apic arat avic avx avx2
    bmi1 bmi2 bpext clflush cmov cmp_legacy constant_tsc cpb cpuid cr8_legacy
    cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fma4
    fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs lahf_lm lbrv lm lwp mca
    mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nodeid_msr
    nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter
    pclmulqdq pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni popcnt pse
    pse36 ptsc rdtscp rep_good sep skinit smep ssbd sse sse2 sse4_1 sse4_2
    sse4a ssse3 svm svm_lock syscall tbm tce tsc tsc_scale v_vmsave_vmload
    vgif vmcb_clean vme vmmcall wdt xop xsave xsaveopt
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard
    driver: amdgpu v: kernel bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 /
    Radeon 520 Mobile]
    vendor: Hewlett-Packard driver: amdgpu v: kernel alternate: radeon
    bus-ID: 01:00.0 chip-ID: 1002:6660 class-ID: 0380
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Webcam type: USB
    driver: uvcvideo bus-ID: 1-1:2 chip-ID: 05c8:0233 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org 1.21.1.2 compositor: xfwm4 v: 4.16.1 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
  OpenGL: renderer: AMD STONEY (DRM 3.35.0 5.4.169-1-MANJARO LLVM 13.0.0)
    v: 4.5 Mesa 21.3.2 direct render: Yes
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    bus-ID: 00:01.1 chip-ID: 1002:15b3 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a
    class-ID: 0403
  Sound Server-1: ALSA v: k5.4.169-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8168 v: 8.049.02-NAPI modules: r8169
    port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter
    vendor: Hewlett-Packard driver: N/A port: 2000 bus-ID: 03:00.0
    chip-ID: 10ec:d723 class-ID: 0280
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
Bluetooth:
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 2-1.4:3 chip-ID: 0bda:b009 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 465.76 GiB used: 141.67 GiB (30.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 4C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 457.74 GiB size: 449.48 GiB (98.20%)
    used: 141.67 GiB (31.5%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 584e4a68-ed04-42c2-892d-f3f6f50f3761
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 2656-63D7
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.52 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: a4a9ed97-abcd-4b36-bb0b-1e236d350a31
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Cheng Uei Precision Industry (Foxlink) HP Webcam
    type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 05c8:0233 class-ID: 0e02 serial: <filter>
  Device-2: 1-2:3
    info: SHARKOON 2.4GHz Wireless rechargeable vertical mouse [More&Better]
    type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 1ea7:0064 class-ID: 0301
  Hub-2: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-3: 2-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0
    speed: 480 Mb/s power: 100mA chip-ID: 0438:7900 class-ID: 0900
  Device-1: 2-1.4:3 info: Realtek Realtek Bluetooth 4.2 Adapter
    type: Bluetooth driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 500mA chip-ID: 0bda:b009 class-ID: e001 serial: <filter>
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 57.0 C mobo: 20.0 C
  Fan Speeds (RPM): N/A
  GPU: device: amdgpu temp: 42.0 C device: amdgpu temp: 56.0 C
Info:
  Processes: 171 Uptime: 1m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1437 lib: 479
  flatpak: 0 Shell: Bash v: 5.1.12 running-in: xfce4-terminal inxi: 3.3.11

The problem seems to be the missing rtw_8723de drier for Realtek RTL8723DE 802.11b/g/n PCIe Adapter and I don’t seem to find it anywhere. What can I do?

There seems to be an AUR package for RTL8723DE, did you try that one?
https://aur.archlinux.org/packages/rtl8723de-dkms-git/

yes, it didn’t work.

Found a solution in this thread: RTL8723DE - Wifi Driver Installation - Networking - Manjaro Linux Forum

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.