No Wi-Fi after Kernel update

I am using the broadcom-wl module for Wi-Fi. After a kernel update and reboot today I no longer have access to my wireless network. I have tried reinstalling the package with no luck. Does anyone have any advice on other things to try?

Welcome at the forum, @tjfriese

Please provide

inxi -Fazy
pacman -Qs broadcom
lspci -v
  Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=21798f2b-1084-4559-b9da-a8d8fa392f4a rw quiet apparmor=1 
  security=apparmor resume=UUID=c31a8c42-1e69-492e-b023-30ea6d8f7520 
  Console: tty 2 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux

  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: 5.6.0-k 
  port: f000 bus ID: 05:00.0 chip ID: 8086:1539 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl 
  v: kernel modules: bcma port: f000 bus ID: 06:00.0 chip ID: 14e4:43a0 
  IF: wlo1 state: down mac: <filter>
local/linux54-broadcom-wl (linux54-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.

06:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
        DeviceName: RTL8111EPV
        Subsystem: Broadcom Inc. and subsidiaries Device 0619
        Flags: bus master, fast devsel, latency 0, IRQ 41, IOMMU group 0
        Memory at f7000000 (64-bit, non-prefetchable) [size=32K]
        Memory at f6e00000 (64-bit, non-prefetchable) [size=2M]
        Capabilities: [48] Power Management version 3
        Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [68] Vendor Specific Information: Len=44 <?>
        Capabilities: [ac] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Device Serial Number d0-37-00-ff-ff-00-00-00
        Capabilities: [150] Power Budgeting <?>
        Capabilities: [160] Virtual Channel
        Capabilities: [1b0] Latency Tolerance Reporting
        Capabilities: [220] Physical Resizable BAR
        Kernel driver in use: wl
        Kernel modules: bcma, wl

Please let me know if you need more. I tried pasting the entire files and got an error message about pasting links.

Sometimes it helps to re-install the broadcom driver. There is a dkms version available, too. Try to re-install or install the other version (considering your kernel version) and report.

A post was split to a new topic: No bluetooth, no wifi

How would I go about reinstalling the driver? I have already tried reinstalling the broadcom-wl package through pacman. Could this have something to do with a module not loading?

It depends where the package is located. If the package is located in AUR you could use pamac for installation:

pamac build {package name}

{package name} to be replaced by the real name. When you use packages from AUR make yourself familar wirh AUR.

Only if the package is in the normal Manjaro repos pacman can be used or

pamac install {package name}

Also, please always update your system before installing anything!
Not forget to reboot after installing a driver.

I have tried the following:

pacman -Rs linux54-broadcom-wl
pacman -S broadcom-wl

select the linux54 option (#x86_6)

This has not fixed the issue. Is there anything else that I can try?

Can you explain this? By the way, have you updated your system?

Yes, the system is up to date. When you install the broadcom-wl package it prompts you to select options according to your kernel. I selected the one for the 5.4 kernel.

Have you tried Kernel 5.10?