No WebGL on Firefox with AMD RX570

I am using Manjaro KDE with an AMD Radeon RX570. WebGL doesn't work.

get.webgl.org says that my browser supports WebGL but it is disabled or unavailable. I have tried force enabling it and setting security.sandbox.content.read_path_whitelist to /sys/. Reverted that.

inxi -Fxxxz says this:

System:    Host: manjaro-pc Kernel: 5.4.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.3 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z370 Pro4 serial: <filter> 
           UEFI: American Megatrends v: P1.80 date: 02/22/2018 
CPU:       Topology: 6-Core model: Intel Core i5-8400 bits: 64 type: MCP arch: Kaby Lake rev: A 
           L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33613 
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
           5: 800 6: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASRock driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3e92 
           Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus ID: 01:00.0 
           chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,intel compositor: kwin_x11 
           resolution: 2560x1080~75Hz 
           OpenGL: renderer: Radeon RX 570 Series v: 4.6.13572 Core Profile Context 
           compat-v: 4.6.13572 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
           vendor: Sapphire Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 1002:aaf0 
           Sound Server: ALSA v: k5.4.28-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 
           bus ID: 00:1f.6 chip ID: 8086:15b8 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: TP-Link TL-WN722N v2 type: USB driver: r8188eu bus ID: 1-1:2 
           chip ID: 2357:010c serial: <filter> 
           IF: wlp0s20f0u1 state: up mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 792.47 GiB (75.4%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW128G7 size: 119.24 GiB 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: PSF121C scheme: GPT 
           ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-75WN4A0 size: 931.51 GiB 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A02 scheme: GPT 
Partition: ID-1: / size: 73.88 GiB used: 44.48 GiB (60.2%) fs: ext4 dev: /dev/nvme0n1p5 
           ID-2: swap-1 size: 4.88 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 28.0 C mobo: N/A gpu: amdgpu temp: 25 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 794 
Info:      Processes: 243 Uptime: 1h 12m Memory: 7.64 GiB used: 2.62 GiB (34.3%) Init: systemd 
           v: 244 Compilers: gcc: 9.3.0 clang: 9.0.1 Shell: fish v: 3.1.0 running in: konsole 
           inxi: 3.0.37

How can I fix this?

I am not sure where you got that from but that is not the parameter for enabling anything render related. Revert that change.

Try setting gfx.webrender.all and gfx.webrender.enabled to true. That should do it. If it does not, try layers.acceleration.force-enabled = true in addition to the previous things.

1 Like

Did all three. Restarted Firefox, still no WebGL

can you check webgl.disabled - default should be false. If it is true, try changing it to false.
webgl.force-enabled could be set to true to force the enablement.

Thank you! webgl.force-enabledfixed it.

Well... I also have this issue and this change fixed it for me on Intel HD Graphics...
But still don't know why it's still broken. The idea is coming from https://bbs.archlinux.org/viewtopic.php?id=239480

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by