No Title Bar on one window in KDE

I tried out No Borders on a Window. Now I have no title bar either. How do I bring it back for just this single window?

See krules in systemsettings

System settings - Window management - Window rules

1 Like

System settings - Window management - Window rules

This is what I see

This is the menu you mentioned but I see no way to resolve the problem here

You should find an existing rule for that app and nuke it, not add some new one.

You should find an existing rule for that app and nuke it, not add some new one.

Looking at the screenshot, there is no existing rule to nuke.

What is the application and how did you install it?

Zoiper. I installed it through the AUR.

wow, I just tried - it failed to build for me.

You have to download the .tar file from zoiper directly and leave it in your downloads folder, then install via AUR. It will work fine.

  1. open both, krules and the window of app you want titlebar.
  2. press on “detect window properties” and click on the other app window.
  3. add conditions for rule(appname, title, etc…).
  4. add the properties you want change(titlebar,geometry , position…)
  5. press apply.

*) note1: if one property is ignored change to force in the property settings.
*) note2: some applications change immediately others needs to reopen window.

Oddly, I was having trouble where the shadows had disappeared and had created another thread about that. Someone told me to go to Compositor and I did and it not only fixed the shadows, but oddly it brought back the title bar for Zoiper. Not sure why.

Weird, that setting looks completely different for me:

I have one rule and can delete it. I can add new one through the button below. You have button in the middle.

Bizarro world here. A restart and Zoiper again has no title bar.

I tried the detect option and tried several settings that might fix it but no dice.

You’re in the “new rule” section:

But I was talking about another, “previous” step:

1 Like