No such cryptodisk error message with no error on boot/reboot!

I run manjaro i3 community at home and at work on x1 Carbon and T14 gen2 Thinkpads. My home kernel is 5.15 at work I am on 6.11. I noticed a weird error message creeping in every time I boot or reboot. The error states “no such cryptodisk press any key to continue” after I correctly enter the password to unencrypt the disk then the computer continues to boot as normal. So there is no real issue with anything. The password is correct the machine boots as normal but it bugs me to receive error messages. At first it was only on the newer version at work but it just started at home as well. Does anyone have any idea where this cryptic message comes from? Thanks.

Can’t really help except to say that this has been the topic of many recent threads here.
Read through them and you’ll likely find an answer.

1 Like

There has been a lot of discussion already.
You might find a solution under the known issues of the release notes:

1 Like

The solution is from this thread. I’ll post it here again, to make it easy, if someone else is looking for it here. It works very well for me and I hope it will help you, too.

Remove the dash separators for all cryptomount -u entries

cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 (example)
cryptomount -u 3722dfb23b32414bbd594329fa92b6a9

in /boot/grub/grub.cfg

To edit the grub.cfg I had to

sudo chmod 644 /boot/grub/grub.cfg

Even on a fresh Manjaro installation with encryption that error appears after the first update and reboot. I hope they will fix that soon.

1 Like

Please also look at:

Thanks for this. I noticed the dash separators are not there in the file when I run the 5.15 kernel. I am troubleshooting another issue at present and have reverted to 515 so I will check back later to see if this solves it.