No sound (ubuntu ok / manjaro problem)

Hello

I dont know why i havent got sound on my manjaro after instalation.
On my ubuntu it working ok (command aplay -D plughw:1,0 /usr/share/sounds/alsa/Front_Left.wav working after tips from linuxium

But on this system i dont know what to do. Changing pulse/default.pa is not working.

After comand aplay -L i dont see full list my devices like on ubuntu/lubuntu like plughw:0,1
there is only:

aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=chtrt5645
    chtrt5645, 
    Default Audio Device
usbstream:CARD=chtrt5645
    chtrt5645
    USB Stream Output
sysdefault:CARD=Audio
    Intel HDMI/DP LPE Audio, Intel HDMI/DP LPE Audi
    Default Audio Device
hdmi:CARD=Audio,DEV=0
    Intel HDMI/DP LPE Audio, Intel HDMI/DP LPE Audi
    HDMI Audio Output
hdmi:CARD=Audio,DEV=1
    Intel HDMI/DP LPE Audio, Intel HDMI/DP LPE Audi
    HDMI Audio Output
hdmi:CARD=Audio,DEV=2
    Intel HDMI/DP LPE Audio, Intel HDMI/DP LPE Audi
    HDMI Audio Output
usbstream:CARD=Audio
    Intel HDMI/DP LPE Audio
    USB Stream Output

Please use proper formatting and post your inxi -Fxxxz output.

aplay command uses Captal and lower case letter ‘L’ as 2 different commands
so you may want to try aplay -l for list of hardware devices

but suggest use alsa-info.sh to get all the ALSA information at once

did you have working sound on Manjaro Live boot before installing?

Thanks for reply . No , before instalation on live cd dont work.

But if i remember it was working 1 month ago in the same device

Maybe it is becouse i dont make availible updates (over 500 mb to download) ? But i dont want to install every “extra package”. This distro (18 KDE ) working really good but this sound … (and bluetooth is not working too but this is no big problem)

**** List of PLAYBACK Hardware Devices ****
card 0: chtrt5645 [chtrt5645], device 0: Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: chtrt5645 [chtrt5645], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This is not Ubuntu. Not updating WILL break your system. Maybe not today, or tomorrow, but eventually not updating will break it. Update.

Lol on the other pc i have never update my cool linux mint (over 5 years and it is still good) so why i need to do it here ? Lol i got a fresh distro and i only want working sound…

Quite simply because most likely no one is going to help you fix your problem if it is not.

Linux mint is a release based distro. This is rolling. So if you only update what you want, it will in short order break as packages end up out of sync. And if you actually did not update for five years good for you, why you would choose to have an outdated, increasingly insecure install is beyond me.

1 Like

next problem, i cant open chromium browser…

I recommend you update and reboot.

very unlikely additional problems with chromium and bluetooth will get any attention due to title of post. suspect this is related to lack of audio

suggest you read this:
https://wiki.manjaro.org/index.php?title=Forum_Rules#Life_is_a_Two-way_Street
to understand how this forum operates

If you have another working version of Ubuntu or Mint, suggest you run alsa-info on that too
https://wiki.ubuntu.com/Audio/AlsaInfo
then you can compare information from working ALSA to non-working ALSA

I’m sorry if this may sound harsh. You claim that you have used Mint over 5 years, so I would at least expect some basic understanding of how your system works. The question why you should update I would expect from a newcomer ( maybe ), but with 5 years experience … I mean, are you trolling?

1 Like

guys … just please fix my problem if u are so “pro” . But my digression. If u traveling to the work every day with the same bus it is mean u have experience of driving like a driver ??

lol

My lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register [8086:2280] (rev 22)
00:02.0 VGA compatible controller [0300]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers [8086:22b0] (rev 22)
00:03.0 Multimedia controller [0480]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit [8086:22b8] (rev 22)
00:0a.0 Non-VGA unclassified device [0000]: Intel Corporation Device [8086:22d8] (rev 22)
00:0b.0 Signal processing controller [1180]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller [8086:22dc] (rev 22)
00:14.0 USB controller [0c03]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller [8086:22b5] (rev 22)
00:16.0 USB controller [0c03]: Intel Corporation Device [8086:22b7] (rev 22)
00:1a.0 Encryption controller [1080]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine [8086:2298] (rev 22)
00:1f.0 ISA bridge [0601]: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU [8086:229c] (rev 22)

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: chtrt5645 [chtrt5645], device 0: Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: chtrt5645 [chtrt5645], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

my 50-pulseadudio.conf

_Add a specific named PulseAudio pcm and ctl (typically useful for testing)_

pcm.pulse {
	type pulse
	hint {
		show {
			@func refer
			name defaults.namehint.basic
		}
		description "PulseAudio Sound Server"
	}
}

ctl.pulse {
	type pulse
}

cat /proc/asound/devices

  2: [ 0- 0]: digital audio playback
  3: [ 0- 0]: digital audio capture
  4: [ 0- 1]: digital audio playback
  5: [ 0]   : control
  6: [ 1- 0]: digital audio playback
  7: [ 1- 1]: digital audio playback
  8: [ 1- 2]: digital audio playback
  9: [ 1]   : control
 33:        : timer

cat /proc/asound/cards

 0 [chtrt5645      ]: chtrt5645 - chtrt5645
                   Defaultstring-CherryTrailCR
 1 [Audio          ]: HdmiLpeAudio - Intel HDMI/DP LPE Audio
                      Intel HDMI/DP LPE Audio

asound.conf

_Use PulseAudio by default_
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"
  }
}

ctl.!default {
  type pulse
  fallback "sysdefault"
}

# vim:set ft=alsaconf:

We can’t fix your problem.

We can only give suggestions as to how you can fix your problem.

Suggestion: You certain that your sound device is not muted in alsamixer?

Look at this (on ubuntu sound was working after this command **

lay -D plughw:0,1 /usr/share/sounds/alsa/Front_Left.wav

Playing WAVE ‘/usr/share/sounds/alsa/Front_Left.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1403: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: S16_LE
SUBFORMAT: STD
SAMPLE_BITS: 16
FRAME_BITS: 16
CHANNELS: 1
RATE: 48000
PERIOD_TIME: 125000
PERIOD_SIZE: 6000
PERIOD_BYTES: 12000
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 24000
BUFFER_BYTES: 48000
TICK_TIME: 0

and

aplay -D plughw:0,1 /usr/share/sounds/alsa/Front_Left.wav

Playing WAVE ‘/usr/share/sounds/alsa/Front_Left.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1403: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: S16_LE
SUBFORMAT: STD
SAMPLE_BITS: 16
FRAME_BITS: 16
CHANNELS: 1
RATE: 48000
PERIOD_TIME: 125000
PERIOD_SIZE: 6000
PERIOD_BYTES: 12000
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 24000
BUFFER_BYTES: 48000
TICK_TIME: 0

Still no sound…

aplay: set_params:1403: Unable to install hw params:

might be that Ubuntu is able to remix mono to both stereo channels, but not Manjaro

Try both of these to test ALSA in stereo:

speaker-test -D hw:0,1 -c 2 -l 2

speaker-test -D hw:0,0 -c 2 -l 2

for hw:
speaker-test 1.1.7

Playback device is plughw:0,0
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 16 to 204800
Period size range from 8 to 102400
Using max buffer size 204800
Periods = 4
Unable to set hw params for playback: Bad argument
Setting of hwparams failed: Bad argument

for plughw:
speaker-test 1.1.7

Playback device is plugwhw:0,0
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM plugwhw:0,0
Playback open error: -2,There is no such file or directory

really so hard…

How can reset all setting to default and try to configure it all again without reinstalling the system … ?

looks like typo from extra ‘w’

speaker-test direct to the 2 audio subdevices hw:0,0 and hw:0,1 is different to using with the ALSA plug pcm
a command with “hw:0,1” shouldn’t be changing to “plughw:0,0”

but looking at your other comments, and about resetting:

Manjaro is not going to be much fun for you if you are not wanting many updates
if your sound wasn’t working on Live version before installing it isn’t likely to start working after install
the only likely way that sound might start working is by updating, but there is no way to know for sure

Suggest you get a recent version of Mint or Ubuntu and try that out with just Live boot
You can try a lot of the stuff mentioned here to check for any audio problems

If you have audio working in another Linux version you can always choose to go with that, or boot back in to Manjaro and try matching settings to those from more familiar distribution

it is not abouty typo.

Dummy Output problem is still not fixed . I don’t know what else I can try out

my journalctr

kernel: Linux version 4.19.0-3-MANJARO (builduser@development) (gcc version 8.2.1 20180831 (GCC)) #1 SMP PREEMPT Sat Oct 27 22:40:22 >
dec 15 20:34:03 sylvt11 kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=1c4e2a28-28e3-4982-90df-b20e6ec0aa18 rw quiet resume=UUID=7d6769>
dec 15 20:34:03 sylvt11 kernel: KERNEL supported cpus:
dec 15 20:34:03 sylvt11 kernel: Intel GenuineIntel
dec 15 20:34:03 sylvt11 kernel: AMD AuthenticAMD
dec 15 20:34:03 sylvt11 kernel: Centaur CentaurHauls
dec 15 20:34:03 sylvt11 kernel: x86/fpu: x87 FPU will use FXSAVE
dec 15 20:34:03 sylvt11 kernel: BIOS-provided physical RAM map:
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000008efff] usable
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000000008f000-0x000000000008ffff] ACPI NVS
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x0000000000090000-0x000000000009dfff] usable
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000000009e000-0x000000000009ffff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x0000000000100000-0x000000001effffff] usable
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000001f000000-0x00000000201fffff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x0000000020200000-0x000000007b155fff] usable
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000007b156000-0x000000007b185fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000007b186000-0x000000007b1b4fff] ACPI data
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000007b1b5000-0x000000007b77cfff] ACPI NVS
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000007b77d000-0x000000007ba4cfff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000007ba4d000-0x000000007baabfff] type 20
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x000000007baac000-0x000000007bffffff] usable
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000e0000000-0x00000000e3ffffff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fea00000-0x00000000feafffff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fed01000-0x00000000fed01fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fed03000-0x00000000fed03fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fed06000-0x00000000fed06fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fed08000-0x00000000fed09fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fed1c000-0x00000000fed1cfff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fed80000-0x00000000fedbffff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x00000000ffc00000-0x00000000ffffffff] reserved
dec 15 20:34:03 sylvt11 kernel: BIOS-e820: [mem 0x0000000100000000-0x000000017fffffff] usable
dec 15 20:34:03 sylvt11 kernel: NX (Execute Disable) protection: active
dec 15 20:34:03 sylvt11 kernel: efi: EFI v2.40 by Teclast
dec 15 20:34:03 sylvt11 kernel: efi: ESRT=0x7b184000 ACPI=0x7b18f000 ACPI 2.0=0x7b18f000 SMBIOS=0x7b93d000 SMBIOS 3.0=0x7b93c000
dec 15 20:34:03 sylvt11 kernel: SMBIOS 3.0.0 present