No sound through all output channels after update

My Manjaro install upgraded yesterday and after reboot I lost sound output from speaker, wired headphone and bluetooth. I only have Manjaro Linux in my laptop (no duel boot).

I had kernel 5.9.16-1 even after update. I manually upgraded to 5.10.59-1 today with no luck getting back sound.

When I run
inxi -Faz

I get this

System:    Kernel: 5.10.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=01e6c1d9-5825-4b3c-b03d-96752433aa3e ro 
           nouveau.modset=0 quiet apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: ASUSTeK product: ZenBook UX434DA_UM433DA v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: UX434DA v: 1.0 serial: <filter> UEFI: American Megatrends v: UX434DA_UM433DA.302 
           date: 09/05/2019 
Battery:   ID-1: BAT0 charge: 41.8 Wh (100.0%) condition: 41.8/50.0 Wh (83.7%) volts: 11.9 min: 11.9 
           model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging cycles: 82 
CPU:       Info: Quad Core model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen 
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 36751 
           Speed: 1294 MHz min/max: 1400/2300 MHz boost: enabled Core speeds (MHz): 1: 1294 2: 1486 3: 1209 4: 1177 5: 1213 
           6: 1177 7: 1359 8: 1174 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 03:00.0 
           chip-ID: 1002:15d8 class-ID: 0300 
           Device-2: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo bus-ID: 3-2:3 chip-ID: 13d3:56cb 
           class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x174mm (12.2x6.9") diag: 355mm (14") 
           OpenGL: renderer: AMD Radeon Vega 10 Graphics (RAVEN DRM 3.40.0 5.10.59-1-MANJARO LLVM 12.0.1) 
           v: 4.6 Mesa 21.1.6 direct render: Yes 
Audio:     Device-1: Advanced Micro D![audio settings|689x482, 75%](upload://sOiP2RfPWx9fNlWP8ttDEBuUDyw.png)
evices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
           alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.59-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280 
           IF: wlp1s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0a2b 
           class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
Drives:    Local Storage: total: 476.94 GiB used: 43.07 GiB (9.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GDJTNG-8310A size: 476.94 GiB block-size: 
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: 80001C00 temp: 42.9 C 
           scheme: GPT 
Partition: ID-1: / raw-size: 50 GiB size: 48.97 GiB (97.93%) used: 21.56 GiB (44.0%) fs: ext4 dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 410.44 GiB size: 403 GiB (98.19%) used: 21.51 GiB (5.3%) fs: ext4 dev: /dev/nvme0n1p4 
           maj-min: 259:4 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 60.6 C mobo: 60.0 C gpu: amdgpu temp: 60.0 C 
           Fan Speeds (RPM): cpu: 2800 
Info:      Processes: 256 Uptime: 11m wakeups: 464 Memory: 13.67 GiB used: 2.6 GiB (19.0%) Init: systemd v: 248 
           tool: systemctl Compilers: gcc: 11.1.0 Packages: 1410 pacman: 1403 lib: 401 flatpak: 0 snap: 7 Shell: Bash 
           v: 5.1.8 running-in: konsole inxi: 3.3.06

I noticed in my system settings for audio, the Audio Controller profile simply has “Off” with nothing else to chose for. To be honest I never checked it before if there was a profile set

Have you checked your pavucontroller?

Issue No audio after Pulseaudio v15 update:

Try clearing the databases in your home folder of any old settings by executing:

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

Reboot afterwards.

1 Like

Check what?

PulseAudio Volume Control ( pavucontrol ) is not installed in KDE because KDE has it’s own Audio GUI controls
if an additional GUI is needed, a KDE user would probably prefer to install pavucontrol-qt rather than the GTK package

But OP comment about a PulseAudio profile suggests audio settings have already been checked

System data is showing 2nd of 3 audio devices is not loading available drivers

Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480 

This device is the AMD audio co-processor (acp) to support digital array microphones (cortana), similar to Intel Sound Open Firmware (sof)

I suggest you install kernel v5.13 and check if the audio driver is loaded for the ACP device

1 Like

This worked. Though I needed to do this a few times. The 3rd time worked!

1 Like

What you wrote made sense. However, clearing pulse audio database had sound working again. If there is further issues, I’ll try upgrading the kernel. Thanks anyway.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.