No sound on new xfce install

I’m getting absolutely no sound on my new xfce install. And I’m not seeing any solutions from the recommend similar threads. The closest thing I could find is a kernel patch to an outdated kernel version from last year(v5.13),

output of inxi -Aazy

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=76311d73-ac03-40c3-a468-f1e3d547948e rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Micro-Star product: Modern 14 B10MW v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-14D1 v: REV:1.0 serial: <superuser required>
    BIOS: American Megatrends v: E14D1IMS.10B date: 12/22/2020
  ID-1: BAT1 charge: 26.9 Wh (100.0%) condition: 26.9/37.8 Wh (71.1%)
    volts: 12.1 min: 11.4 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: full
  Info: model: Intel Core i3-10110U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 built: 2018
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xC (12)
    microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 400 min/max: 400/4100 scaling: driver: intel_pstate
    governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 bogomips: 20810
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9b41
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x08d7 built: 2019 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:02c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:3 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 119.24 GiB used: 8.96 GiB (7.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3128B-AI1
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: EDFK0S03
    temp: 45.9 C scheme: MBR
  ID-1: / raw-size: 119.24 GiB size: 116.81 GiB (97.96%) used: 8.96 GiB
    (7.7%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 56.0 C pch: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 201 Uptime: 1h 28m wakeups: 1 Memory: 7.59 GiB used: 2.59 GiB
  (34.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1084 lib: 324
  flatpak: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.20

output of uname -a:

Linux twelve 5.15.60-1-MANJARO #1 SMP PREEMPT Thu Aug 11 13:14:05 UTC 2022 x86_64 GNU/Linux

Do you have package sof-firmware installed? I do seem to have it even without relevant hardware:

rene@p55m:~$ pacman -Ss sof-firmware
extra/sof-firmware 2.2.2-1 [installed]
    Sound Open Firmware

so maybe you also already do but if not then I expect that installing that and rebooting might work. I.e., Comet Lake PCH-LP cAVS sound card not detected after latest update

Yep, already have it and I rebooted just to make sure. Still no dice. :slightly_frowning_face:

Hrmpf. That’s likely mean I end up not being helpful, but does in your case the card show up in your pactl list output?

Well, when I enter…

pactl list | grep sof-firmware


pactl list | grep sof

Nothing appears in both cases

Well, it wouldn’t; you are listing your soundcards there, not installed software. Wanted to know whether or not the device exists at the Pulseaudio level.

However. Google-Fu is urging to try something else: after potentially sudo pacman -S downgrade if you don’t have it installed already, and using

sudo DOWNGRADE_FROM_ALA=1 downgrade sof-firmware

to downgrade sof-firmware to 2.1.1a and rebooting once more, do you then have sound?

Done! Still nothing.

Nah, crap. We may need to eventually look at sudo dmesg >~/dmesg.out but I then for now have only fairly lame advise to try a newer kernel and see if anything’s fixed. You can install e.g. 6.0.8-1 easily from Manjaro Settings Manager → Kernel. You’ll again need to reboot when installing a new kernel.

I’d by the way also update sof-firmware again now that that didn’t help; sudo pacman -Sy sof-firmware

Done still no luck. Was i suppose to remove the old kernel afterwords?

and the results of the above command returned nothing, both before and after the kernel change + reboot.

No, if uname -a now says you’re on 6.0.8 you’re good. And, yes, that command certainly did return something, specifically, the file dmesg (or dmesg.out if you used my version) in your home-directory which now consists of the kernel’s startup information and supposedly/maybe then information as to why your sound is crapping out.

Not sure I’m going to be helpful now that the low-hanging fruit’s gone but if you want you can attach that mentioned file to this post (or if it’s too big, post it on some kind of pastebin online for us to look at). If you do, look through it first for any potential privacy matters.

Here’s the the link to the file dmesg.out

under the raw data tab.

That dmesg is from kernel 5.15.60-1 so just to be sure: uname -a now tells you you’re on 6.0.8-1?

There’s in any case nothing of interest in there regarding audio – except then that it seems all’s in fact fine. As such I will again need to ask if e.g. pactl list cards shows the “HDA Intel” card. And/or whether or not you see the Pulseaudio plugin on your systray (the speaker icon) and if the card’s shown if you click that.

I’ve seen others suggest to try and have just one of Pulseaudio and Pipewire running. You have both – but I also have and this should be fine.

yes uname -r outputs:


and yes this command

pactl list cards | grep intel


alsa.driver_name = “snd_hda_intel”

As far as the system tray- I see the speaker icon, but I don’t see anything about an intel hda card when I click it.

Cant promise you this is going anywhere but lets then check one level down; can you post the output of aplay -l?


**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC233 Analog [ALC233 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

More “all’s fine – nothing to see here” output…

Does speaker-test -D hw:0 -c 2 -t sine -l 1 produce sound? (a sine first on one, then the other channel).

If not; does alsamixer -c 0 show all volumes not zero and no channels muted, i.e., all with a “OO” in green under the sliders as in the attached example?


nope. no sound from the first command.

the alsamixer does look a bit weird to me.

Still not seeing any issue and fairly specifically not seeing any issue that would keep Pulseaudio from providing you with a fully functional Pulseaudio plugin complete with e.g. volume controls when clicked in the systray – which you appear to say you did not have.

Please confirm: no controls visible from clicking the speaker icon in the systray? No possibility to from there go to the “audio mixer”?

If not (and only if not):

$ systemctl --user stop pulseaudio.socket
$ systemctl --user stop pulseaudio.service
$ pulseaudio -vv 2>&1 | tee ~/pulseaudio.log
$ systemctl --user start pulseaudio.service
$ systemctl --user start pulseaudio.socket

and again then please upload the file “pulseaudio.log” in your home directory for us to look at.

It’s however starting to look very misty…

no, the volume controls are in the tray, i said i just don’t see anything abou hda intel sound card there.

Can you post a screenshot of the “PulseAudio Volume Control” window, “Output devices” tab? I.e., as per