No sound on Legion 7 speakers, Bluetooth headphones works

Hi, so I am having some problem with my sound on my Legion 7. I tried to update my kernel to 5.15 but that did not help. The sound will work on my BT headphones. and I can see that my PC picks up sound from firefox as I can see the soundbar moving in the settings window.

  ~  inxi --admin --verbosity=7 --filter --width           ✔ 
  Kernel: 5.15.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=333f6e70-9683-450e-ac01-16ab6d323b1f rw quiet
  root=/dev/mapper/luks-394675e1-92c4-48c6-901d-592f7f77b906 splash apparmor=1
  Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82N6 v: Legion 7 16ACHg6
  serial: <filter> Chassis: type: 10 v: Legion 7 16ACHg6 serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter>
  UEFI: LENOVO v: GKCN44WW date: 08/30/2021
  ID-1: BAT0 charge: 82.2 Wh (100.0%) condition: 82.2/80.0 Wh (102.7%)
  volts: 17.4 min: 15.4 model: Celxpert L20C4PC1 type: Li-poly
  serial: <filter> status: Full cycles: 6
  RAM: total: 15.55 GiB used: 1.69 GiB (10.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: 8-Core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
  type: MT MCP arch: Zen 3 family: 19 (25) model-id: 50 (80) stepping: 0
  microcode: A50000C cache: L2: 4 MiB bogomips: 102241
  Speed: 1197 MHz min/max: 1200/3200 MHz boost: enabled Core speeds (MHz):
  1: 1197 2: 1197 3: 1197 4: 1197 5: 1197 6: 1197 7: 1197 8: 1197 9: 1197
  10: 1197 11: 1198 12: 1197 13: 1397 14: 1397 15: 1198 16: 1197
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
  cr8_legacy cx16 cx8 de decodeassists erms extapic extd_apicid f16c
  flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
  invpcid irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor
  movbe msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx ospke osvw
  overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core
  perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt pse pse36 rapl rdpid
  rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni skinit smap smca smep
  ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall
  tce topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vaes vgif
  vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt xgetbv1 xsave xsavec
  xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
  STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB]
  vendor: Lenovo driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm
  bus-ID: 01:00.0 chip-ID: 10de:24dc class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:3
  chip-ID: 04f2:b67d class-ID: 0e02
  Display: x11 server: 1.20.13 compositor: gnome-shell driver:
  loaded: nvidia resolution: <missing: xdpyinfo>
  OpenGL: renderer: NVIDIA GeForce RTX 3080 Laptop GPU/PCIe/SSE2
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
  Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel v: kernel
  bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Lenovo driver: r8169 v: kernel port: 1000 bus-ID: 03:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
  driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:2
  chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-394675e1-92c4-48c6-901d-592f7f77b906 maj-min: 254:0
  type: LUKS dm: dm-0 size: 215.55 GiB
  p-1: nvme1n1p2 maj-min: 259:2 size: 215.56 GiB
  Device-2: luks-a3aaad29-5fb0-4f44-858b-85d1cb28646a maj-min: 254:1
  type: LUKS dm: dm-1 size: 17.03 GiB
  p-1: nvme1n1p3 maj-min: 259:3 size: 17.03 GiB
  Message: No RAID data found.
  Local Storage: total: 1.16 TiB used: 27.24 GiB (2.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: MZVLB1T0HBLR-000L2
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 3L1QEXF7 temp: 40.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
  model: WDS250G2B0C-00PXH0 size: 232.89 GiB block-size: physical: 512 B
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
  rev: 211210WD temp: 32.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 215.55 GiB size: 211.11 GiB (97.94%)
  used: 27.24 GiB (12.9%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-394675e1-92c4-48c6-901d-592f7f77b906 label: N/A
  uuid: 333f6e70-9683-450e-ac01-16ab6d323b1f
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 444 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
  label: NO_LABEL uuid: D6A5-0689
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.03 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/dm-1 maj-min: 254:1
  mapped: luks-a3aaad29-5fb0-4f44-858b-85d1cb28646a label: swap
  uuid: 994f0f94-75b4-4dd3-9f61-dc273cf1a938
  ID-1: /dev/nvme0n1p1 maj-min: 259:5 size: 260 MiB fs: vfat label: SYSTEM_DRV
  uuid: EE4F-63E4
  ID-2: /dev/nvme0n1p2 maj-min: 259:6 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:7 size: 952.62 GiB fs: ntfs
  label: Windows-SSD uuid: EC045016044FE266
  ID-4: /dev/nvme0n1p4 maj-min: 259:8 size: 1000 MiB fs: ntfs label: WINRE_DRV
  uuid: 729C50999C5059A5
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 3 rev: 2.1 speed: 480 Mb/s
  chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-3:3 info: Chicony Integrated Camera type: Video driver: uvcvideo
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b67d
  class-ID: 0e02
  Device-2: 1-4:4 info: Integrated Express ITE Device(8258) type: Keyboard
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 048d:c968 class-ID: 0301
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-2:2 info: Genesys Logic USB3.2 Hub ports: 3 rev: 3.2 speed: 5 Gb/s
  chip-ID: 05e3:0620 class-ID: 0900
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-4:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
  class-ID: e001
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Message: No sensor data found. Is lm-sensors configured?
  Processes: 335 Uptime: 7m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: N/A Packages: pacman: 1253 lib: 406 flatpak: 0 Shell: Zsh
  v: 5.8 running-in: gnome-terminal inxi: 3.3.08

What do I need to do to fix this?

Probably some configuration needs to be done as not all system - internally - routes sound the same way.

Have a look at below page - especially the unmute section

I tried

amixer sset Master unmute                           1 ✘ 
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]

That did nothing.

I also tried alsamixer. I turned everything on for both sound cards, that did not help.
I have never done this before so is there something else I need to try?

An amixer command without the card number is only capable of adjusting the default virtual audio controls for PulseAudio input/output levels

I suggest you get information about ALSA controls for onboard audio with this command

amixer --card=1

There was a similar issue happening with legion 7i (2020) and got fixed in recent kernel update after being debugged in https:// show_bug.cgi?id=208555 . I think they are still trying to fix it for the 2021 model

1 Like