No sound on KDE and i3 (but have it on Cinnamon) on fresh install

Hello everybody,

I did a fresh install on a laptop with an intel i7-11800H with Manjaro Cinnamon (latest freshly downloaded) and everything was smooth during installation. On the first boot however I did not have any sound but the keyboard media keys related to the sound (mute, volume up/down and mic on/off) were working and the related overlay display were also working while having no sound. But since I saw a pretty big update in the software manager I did run the updates. On the next boot, I had the sound and everything.

Then I started over with Manjaro KDE (and actually also tried with i3 version) and did the same install. But this time on the first boot I still had no sound but also the keyboard media keys were no working. But this time I didn’t have a big update so the sound is still not working.

This is the output of inxi and this is the exact same output I got in Cinnamon and on KDE:

Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
       alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0401
       Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
       Sound Server-2: JACK v: 1.9.19 running: no
       Sound Server-3: PulseAudio v: 15.0 running: yes
       Sound Server-4: PipeWire v: 0.3.38 running: yes

So it doesn’t seem to miss any driver.

Can anyone guide me on how to check what is there in Cinnamon that’s missing in KDE?
Or what else I need to check?

Thank you very much.

I can run any command in both versions since I can reinstall them (still have both USB installation drives and the installation took a few minutes only).

Edit: I also tried XFCE in addition to KDE and i3 versions which also had the same problem.
Edit 2: The Kernel upon installations of all of these is 5.13.19-2 ( I also tried with upgrading to 5.14.10-1 without success)

I just installed sof-firmware which was present in Cinnamon but not in the other.
And it worked right away (after the boot obviously).


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.