No sound on Asus c436 (Comet lake)

Hello Everyone!
I bought a used laptop Asus c436 (i5, Comet lake) and have maneged to install Manjaro 36.
So far its working like charm! Only two issues are touchscreen and sound. I had read the posts in the forum, but couldnt get the sound working. I did install sof-firmware (I think so).
I have ALSA Information Script, but somehow cant post it ;(
Any help will be apropriate.

A link to the ALSA information can be posted using preformatted text button</>
Or Ctrl+ E

Forum permissions do not allow new users to post active links to prevent spam
but an inactive link is ok

Thanx nikgnomic! Let me try to post it:


So, no one have any suggestions?

post system info:
inxi -Faz

Hello brahma, hier is the info from inxi - Faz

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=411e6129-dcfc-4a32-891d-0f20e5570598 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Google product: Helios v: rev3
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Google model: Helios v: rev3 serial: <superuser required>
    UEFI: coreboot v: MrChromebox-4.17.2 date: 07/18/2022
  ID-1: BAT0 charge: 30.8 Wh (100.0%) condition: 30.8/42.0 Wh (73.3%)
    volts: 12.9 min: 11.9 model: AS2GVUb C436-35 type: Li-ion serial: <filter>
    status: charging cycles: 84
  Info: model: Intel Core i5-10210U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 built: 2018
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xC (12)
    microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 866 high: 900 min/max: 400/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 900 3: 900 4: 900
    5: 900 6: 900 7: 832 8: 800 bogomips: 33615
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-7:2 chip-ID: 13d3:56d4 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x623d built: 2019 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.6
    direct render: Yes
  Device-1: Intel Comet Lake PCH-LP cAVS driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:02c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:3 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 1.14 TiB used: 8.72 GiB (0.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520
    SDAPNUW-256G-1202 size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: 20200000 temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: ASUS model: ROG ESD-S1C
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) used: 8.72 GiB
    (3.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 43.0 C pch: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 241 Uptime: 11m wakeups: 44418 Memory: 15.5 GiB used: 2.03 GiB
  (13.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1171 lib: 316
  flatpak: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.20

edit your post and use formatting - click this icon in editor: </> and copy the output there

Done. Thanx brahma, so looks less paintfull for the eyes

try switching to pipewire:
pamac install manjaro-pipewire wireplumber sof-firmware
it will give you pulse dependency issues, so remove them first, then run the command again;
then install another kernel: go to system settings/kernel and install the 5.19 kernel (dont install the ‘rt’ one);
reboot and check audio

Excuses for the late answer, but after following your advice the system whent to upgrade about 1.3GB, so it took some time. I think the dependencies were removed automaticly. I did install the new kernel 5.19.1 (not the rt one), rebooted, and after running again pamac install manjaro-pipewire wireplumber sof-firmware it gave me this:

    ~  pamac install manjaro-pipewire wireplumber sof-firmware                                        ✔ 
Warning: sof-firmware-2.2.1-1 is up to date -- skipping
Warning: wireplumber-0.4.11-4 is up to date -- skipping
Warning: manjaro-pipewire-20220217-2 is up to date -- skipping
Nothing to do.
Transaction successfully finished.

But still no sound :frowning:

I forgot to mention that I do have sound from the audio jack and from the bluetooth. But not from the speakers

youre not the only one with this issue …
post output from:
inxi -A
pacman -Qs pulse
ls /etc/modprobe.d

inxi -A gave this:

  Device-1: Intel Comet Lake PCH-LP cAVS driver: sof-audio-pci-intel-cnl
  Sound Server-1: ALSA v: k5.19.7-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.57 running: yes

pacman -Qs pulse gave this:

local/lib32-libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification (32-bit)
local/lib32-libpulse 16.1-1
    A featureful, general-purpose sound server (32-bit client libraries)
local/libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification
local/libpulse 16.1-1
    A featureful, general-purpose sound server (client library)
local/pipewire-alsa 1:0.3.57-1.0
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-pulse 1:0.3.57-1.0
    Low-latency audio/video router and processor - PulseAudio replacement
local/plasma-pa 5.25.5-1 (plasma)
    Plasma applet for audio volume management using PulseAudio
local/pulseaudio-alsa 1:
    ALSA Configuration for PulseAudio
local/pulseaudio-ctl 1.70-1
    Control pulseaudio volume from the shell or mapped to keyboard shortcuts.
local/pulseaudio-qt 1.3-1
    Qt bindings for libpulse

And ls /etc/modprobe.d gave nothing at all

remove the pulse leftovers:
pamac remove pulseaudio-alsa pulseaudio-ctl pulseaudio-qt
then create this file:
kate /etc/modprobe.d/audio.conf
and put there this line:
options snd-intel-dspcfg.dsp_driver=1
save the file, reboot and test

Your first command gave this:

    ~  pamac remove pulseaudio-alsa pulseaudio-ctl pulseaudio-qt                                      ✔ 
Checking dependencies...
Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing pulseaudio-qt breaks dependency 'pulseaudio-qt' required by kdeconnect

Should I continue with next commands or I need to uninstall KDE connect (I dont need it)?

if you dont use/need kdeconnect, you can uninstall it … if you use it, keep pulseaudio-qt and remove the 2 other leftovers, then create the file as outlined above, reboot and see if that helped

Done. kdeconnect is gone, followed the 2 commands, rebooted and still no audio.
ls /etc/modprobe.d:

    ~  ls /etc/modprobe.d                                                                             ✔ 

Something to mention (if is not important I will delete this post): after rebooting, on the desktop pops that Comet Lake PCH-LP CAVS Stereo is muted (with icon), and after 2-3 sec. is gone and in the systray audio is unmuted (75% volume in my case). Maybe conflict in the boot proces itself? Or the problem is with the BIOS/motherboard and the sound is disabled from the beginning?

as mentioned, you are not the only one that has issues with this hardware…
run this: alsamixer, press f6, select your card and check if the speakers are not muted…
then try running this:
sudo alsa force-reload
test speakers, if it doesnt work, try this:

amixer -c0 set 'Master',0 100% unmute
amixer -c0 set 'Speaker',0 100% unmute
amixer -c0 set 'Headphone',0 100% unmute

test speakers

I will try with graphics. alsamixer gives:

When pressing F6:

And after choosing default:0 sof-cml… it gives:

Still no audio. But what I see on the 3rd pic - Chip: Intel Kabylake, while I have Cometlake…strange.
And amixer -c0 set ‘Master’,0 100% unmute gives me:

    ~  amixer -c0 set 'Master',0 100% unmute                                                        1 ✘ 
amixer: Unable to find simple control 'Master',0