No sound in Fresh Install

Just made a fresh KDE Install. I can not see a sound input or output devices detected.
Tried the below things so far without any progress, from searching forums/IRC

  1. Installed sof-firmware
  2. Tried using the latest Kernel.
  3. Installed Alsa-tools, but I can only see Icelake HDMI in Codecs
    Output inxi

Device-1: Intel Ice Lake-LP Smart Sound Audio driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:34c8
Sound Server-1: ALSA v: k5.19.1-3-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: yes
Sound Server-4: PipeWire v: 0.3.56 running: yes.

I am getting an option to select Intel HDA PCH On pressing F6 with alsamixer, it doesn’t fix anything.

Please assist. Let me know if any further info is required.

Try only Pipewire: pamac install manjaro-pipewire

The search function on your device might give hints.

1 Like

This is done,

To install (6):
gst-plugin-pipewire 1:0.3.56-1 (Required By: manjaro-pipewire) extra 47.7 kB
pipewire-alsa 1:0.3.56-1.0 (Required By: manjaro-pipewire) extra 5.4 kB
pipewire-pulse 1:0.3.56-1.0 (Required By: manjaro-pipewire) extra 198.6 kB
pipewire-zeroconf 1:0.3.56-1 (Required By: manjaro-pipewire) extra 18.2 kB
manjaro-pipewire 20220217-2 extra 21.5 kB
pipewire-jack 1:0.3.56-1.0 extra 178.9 kB
To remove (5):
jack2 1.9.21-1 (Conflicts With: jack) extra
manjaro-pulse 20220217-2 (Conflicts With: manjaro-pipewire) extra
pulseaudio-bluetooth 16.1-1 (Conflicts With: pipewire-pulse) extra
pulseaudio-zeroconf 16.1-1 (Conflicts With: manjaro-pipewire) extra
pulseaudio 16.1-1 (Conflicts With: pipewire-pulse) extra

Total download size: 470.2 kB
Total installed size: 1.4 MB
Total removed size: 8.6 MB

But didn’t fix anything though.

1 Like

post output from:
pacman -Qs 'pulse|pipewire
there are still some pulse leftovers
use formating, press this icon in the editor: </> and copy the output there

is fast boot disabled in bios - you may not have this option
are you booting with windows? if yes, is fast startup disabled in windows
did the sound worked in live usb?

 pacman -Qs 'pulse|pipewire'                                                                                                                                                                                             INT ✘ 
local/gst-plugin-pipewire 1:0.3.56-1
    Multimedia graph framework - pipewire plugin
local/lib32-libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification (32-bit)
local/lib32-libpulse 16.1-1
    A featureful, general-purpose sound server (32-bit client libraries)
local/libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification
local/libpulse 16.1-1
    A featureful, general-purpose sound server (client library)
local/manjaro-pipewire 20220217-2
    Manjaro meta package for complete PipeWire support.
local/pavucontrol 1:5.0+r35+g964f298-1
    PulseAudio Volume Control
local/pipewire 1:0.3.56-1
    Low-latency audio/video router and processor
local/pipewire-alsa 1:0.3.56-1.0
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-jack 1:0.3.56-1.0
    Low-latency audio/video router and processor - JACK support
local/pipewire-media-session 1:0.4.1-2
    Example session manager for PipeWire
local/pipewire-pulse 1:0.3.56-1.0
    Low-latency audio/video router and processor - PulseAudio replacement
local/pipewire-zeroconf 1:0.3.56-1
    Low-latency audio/video router and processor - Zeroconf support
local/plasma-pa 5.24.6-1 (plasma)
    Plasma applet for audio volume management using PulseAudio
local/pulseaudio-alsa 1:
    ALSA Configuration for PulseAudio
local/pulseaudio-ctl 1.70-1
    Control pulseaudio volume from the shell or mapped to keyboard shortcuts.
local/pulseaudio-qt 1.3-1
    Qt bindings for libpulse

Sound did not work in Live USB, it did in Windows.

remove these:
pamac remove pavucontrol pulseaudio-alsa pulseaudio-ctl
install wireplumber instead of pipewire-media-session:
pamac install wireplumber

so if it didnt work, why did you install it?
and check:

1 Like

I only checked if it works on Live CD post install. Also fastboot is disabled on Windows. Followed the other instructions and rebooted. No progress. Thanks for the suggestions.

try disabling power safe on your audio:
create this file:
kate /etc/modprobe.d/audio.conf
and put there these lines:
options snd_hda_intel power_save=0
options snd_hda_intel power_save_controller=N
save it and run:
sudo mkinitcpio -P
reboot and see if it helped

Can you post the output of alsamixer on console ?

Done. It didn’t help :frowning:


do you have sof-firmware installed?
again open this file:
kate /etc/modprobe.d/audio.conf
and add there this line:
options snd-hda-intel dmic_detect=0
save it and run:
sudo mkinitcpio -P
reboot and see if it helped

Yes I already had sof-firmware. Followed this- No progress.

so again open the audio.conf
and replace all of the options with this:
options snd-intel-dspcfg.dsp_driver=1
so only this one will be there, the power save didnt work, so you need them, save the file and run:
sudo mkinitcpio -P
reboot and see if it helped

Data in post #1 shows audio device is using snd_hda_intel driver and does not show SOF driver as an alternate

Please post more information about ALSA devices

sudo --upload

dmic_detect=0 was deprecated after kernel v5.8. Replacement option snd-intel-dspcfg.dsp_driver=1 to force snd_hda_intel driver is not needed because:

we’ve already got one, it’s a-very nice
( I told him we already got one :smile:)

‘mkinitcpio’ is only needed for GRUB options not for options in /modprobe.d/ folder
power_save settings are usually only needed for eliminating pops and clicks

I have posted before that screenshots of ALSA are usually useless. post#12 is an excellent example

magical beta thinking doesn’t work if the problem is in ALSA. it may need arcane magic or help from a kernel mage

i was following instructions on arch wiki, where there i didnt notice any mention that these options are no longer needed on newer kernels …
and yes you have to run mkinitcpio after you edited modprobe.d modules or their options otherwise they will not be applied

Please find the output of nsudo --upload

ALSA data shows 3 modprobe options added to system

!!Modprobe options (Sound related)

snd_hda_intel: power_save=0
snd_hda_intel: power_save_controller=N
snd_hda_intel: dmic_detect=0

Data also confirms option dmic_detect=0 has been deprecated

!!ALSA/HDA dmesg

[    3.328916] snd_hda_intel 0000:00:1f.3: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

the same message has been appearing in dmesg data since July 2020
Bad audio quality from earphones - Hardware - Manjaro Linux Forum

[@brahma - didn’t notice dmesg data in this post or journal data requested in this post ?]

I suggest you delete modprobe options file

sudo rm /etc/modprobe.d/audio.conf

reboot to ensure modprobe options are not loaded

and get ALSA data again

sudo --upload

ALSA data currently shows only 6 HDMI outputs and no analog output in **** List of PLAYBACK Hardware Devices ****
No analog input detected in **** List of CAPTURE Hardware Devices ****
ALSA is not showing Realtek ALC256 (or similar) device as expected - only Intel Icelake HDMI

Check if manufacturer’s website has any BIOS/Firmware updates
Check BIOS/UEFI settings to ensure onboard audio is turned on

Please find the output post deleting modprobe and rebooting

Hardware seems to be Intel SST But I could not find any updates for Linux. I have a dual boot Windows in which audio is working fine.

1 Like