No sound from speakers or headphones on laptop

im new to linux so idk what im doing, i have a gpd micropc with an intel celeron and i can only get sound from a bluetooth speaker, the built in speaker and the headphone jack just hiss and crackle, sound works fine in windows, im not duel booting either, ive reinstalled manjaro multiple times with either open source or proprietary drivers, messed around with pulseaudio and alsamixer tried different kernals and still nothing.

i rly need help guys, pls explain stuff to me in laymans terms too ive been a dumb windows user since i was 10 so linux is complicated to me.

loads of other people are running linux on the micropc with no problems and the stuff inside this thing is mostly normal intel laptop hardware so i feel like things should be compatable, i also rly like manjaro so far i dont wanna have to go to ubuntu or debian or something

i tried installing linux 5.13 experimental and the sound worked for litterally a breaf moment and then stopped

ok so the sound occasionally works properly at random for like 30 secondss, havnt figured out how to make it do it on purpose tho, i also realised that there is actually sound from the speakers, if i set the speaker volume to 150% and put my ear to the speaker i can faintly hear the sound, its very hissy and crackly but its there, im still pretty sure this is a problem with alsa-utils not being compatable with whatevers in this device, ive tried messing with alsamixer and pulseaudio and havnt been able to make any progress, changing kernels didnt actually seem to improve anything, does anyone more knowledgable about linux know whats different about ubuntu and debian that make them able to work on these devices, do they have different kernals or versions of alsa pipewire or pulse maybe?

ok if i set the audio to use simultaneous output to built in analogue stereo its louder and audible but very distorted it sounds like absolute shit but it is audible sound

nvm it literally just stopped working again, theres now no sound at all suddenly

if anyone wants to help id be happy to post any info that could be useful for diagnosing or fixing my problem but again im new to linux so i dont know what info to post or what commands to use but if anyone wants to help just tell me what commands to type and il post the outputs and provide any other info i can

ok i restarted the whole computer with the same settings that “worked” last time and nothing, i cant figure out any pattern to this it just works occasionally at random, and again this isnt a hardware issue as the sound is loud and clear on windows, and again im not duel booting as ive heard that commonly causes issues like this, the only thing on this thing is fresh manjaro

ok so putting the device to sleep and then waking it up seems to be the thing that makes it work sometimes, the audio is now at full volume, it sounds like shit but its full volume and this is after waking the device from sleep, it doesnt always do this tho so i havnt figured out the full routine for making the sound temporarily work

about a minute after waking the device the sound has gone back to being extremely quiet

plugginmg in headphones doesnt work at all, it keeps flickering between headphones and speakers extremely fast when i do this and get no sound in the headphones

Please open the terminal and:

inxi -Aa

And paste the result here so the forum can try to help you

T+ = See you later

1 Like

inxi -Aa
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
vendor: Realtek driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
chip-ID: 8086:3198 class-ID: 0403
Sound Server-1: ALSA v: k5.13.0-1-MANJARO running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.30 running: no

Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-4: PipeWire v: 0.3.30 running: no
be running?


You can start by reading this thread and posts from it:
Remove Link

Many of the doubts we have about the use of manjaro already exist here on the forum, a little research right here we have already found the fishing rod

T+ = See you later

1 Like

ok il have a read thanks

after doing another inxi -Aa i can see that both pulse and pipe are running. so my problem is these two conflicting?
so i want to kill pipe right?
systemctl --user mask --now pipewire.socket && systemctl --user stop pipewire.service
will do that?
il try putting this in and get back to you

Created symlink /home/uwu/.config/systemd/user/pipewire.socket → /dev/null.
is the output.
audio doesnt seem to be working but theres no hissing atleast, im gonna restart and see if it fixes now

after restarting there is still no sound at all but the hissing has stopped which is certainly an improvement, i checked again with inxi -Aa that pipewire wasnt running.
anything else i can try?

before i was able to get the sound to play a bit but i cant seem to do that now, perhaps i want to enable pipewire and disable pulseaudio instead?
do you think that could solve my issue?

so i just turned on the device and the sound is suddenly working, its much clearer and louder than before but theres a ringing sound coming from the speakers and occasional crackling, this is probably another one o those cases of it working ranndomly again so im sure this wont last but the sound is waaaay better now, il post another update if it stays on or goes off again