No sound after some alsa packages installation


I had no sound issue with Manjaro i3 except no sound in audacity, so for solving that issue installed some packages.

[2023-03-01T19:17:33+0300] [ALPM] removed pasystray (0.8.1-1)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio (16.1-3)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio-equalizer (16.1-3)
[2023-03-01T19:17:33+0300] [ALPM] removed lirc (1:0.10.2-2)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio-lirc (16.1-3)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio-rtp (16.1-3)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio-zeroconf (16.1-3)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio-jack (16.1-3)
[2023-03-01T19:17:33+0300] [ALPM] removed pulseaudio-alsa (1:
[2023-03-01T15:04:58+0300] [ALPM] installed waydroid (1.4.0-1)
[2023-03-01T15:04:47+0300] [ALPM] installed python-gbinder (1.1.1-2)
[2023-03-01T15:04:20+0300] [ALPM] installed libgbinder (1.1.32-1)
[2023-03-01T15:03:56+0300] [ALPM] installed libglibutil (1.0.68-1)
[2023-03-01T15:03:38+0300] [ALPM] installed lxc (1:5.0.2-1)
[2023-03-01T12:58:45+0300] [ALPM] installed pasystray (0.8.1-1)
[2023-03-01T12:57:33+0300] [ALPM] installed pulseaudio-equalizer (16.1-3)
[2023-03-01T12:57:33+0300] [ALPM] installed pulseaudio-lirc (16.1-3)
[2023-03-01T12:57:33+0300] [ALPM] installed pulseaudio-rtp (16.1-3)
[2023-03-01T12:57:33+0300] [ALPM] installed lirc (1:0.10.2-2)
[2023-03-01T12:57:33+0300] [ALPM] installed pulseaudio-zeroconf (16.1-3)
[2023-03-01T12:57:33+0300] [ALPM] installed pulseaudio-jack (16.1-3)
[2023-03-01T12:57:33+0300] [ALPM] installed pulseaudio (16.1-3)
[2023-03-01T12:57:33+0300] [ALPM] installed libusb-compat (0.1.8-1)
[2023-03-01T12:57:33+0300] [ALPM] removed pipewire-pulse (1:0.3.65-6)
[2023-03-01T12:50:11+0300] [ALPM] installed pulseaudio-alsa (1:
[2023-03-01T12:35:32+0300] [ALPM] installed audacity-docs (1:3.2.4-1)
[2023-03-01T12:35:32+0300] [ALPM] installed audacity (1:3.2.4-1)

Then sound gone completely.
I removed these installed packages for fixing issue.
It fixed partially. I can play videos but still no sound.

For solving this issue, removed pulse configuration then
I still couldn’t hear any audio.

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

Here some indicators that sound card seems not

speaker-test -c 2 -t wav -l 10

speaker-test 1.2.8

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm_dmix.c:999:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory
aplay -1L output
aplay: invalid option -- '1'
Try `aplay --help' for more information.

I glanced many things but couldn’t solve this issue? I think I have to recreate conf files but Is there any wrong thing so far?

 inxi -Fxz
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 04:00.1
  Device-2: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 04:00.6
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.65 running: yes

Should I recreate conf files from arch guide or sth else for activating puse audio

Solved with pipewire-pulse reinstallation.

Btw, the sound that I was trying to edit on audacity was problematic that has codec issue only mpv player can read it. These problems occurred by this audio file … what the … aac codec!

Most packages shown as removed/installed belong to PulseAudio. No ALSA packages mentioned

aplay -h advises lower and upper case L options list devices and pcms respectively

-l, --list-devices      list all soundcards and digital audio devices
-L, --list-pcms         list device names

I suspect the command intended to check ALSA should have been

aplay -lL
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.