No sound after fresh install of manjaro xfce . kernel 5.8.6-1-MANJARO

You also need to execute this then as root, see my additions above.

there is two card listed in the folder sound

card0  controlC0  hwC0D0    pcmC0D7p  pcmC0D9p
card1  controlC1  pcmC0D3p  pcmC0D8p  timer

Check in which of the two folders you find “reconfig”, I guess the second. Could also work with the first one.


controlC0  hwC0D0  input5  input7  number    pcmC0D7p  pcmC0D9p  subsystem
device     id      input6  input8  pcmC0D3p  pcmC0D8p  power     uevent

card 1

controlC1  device  id  number  power  subsystem  uevent

I would try the command with card0. Remember, you need root rights (sudo su). Afterwards leave it by exit to return to your normal userspace.

sudo su
echo 1 > /sys/class/sound/card0/reconfig

Another question would be if the issues are linked you the kernel you are using. Sometimes older kernel work better for older hardware. Have you tried kernel 4.14 and 4.19?

I am in root but its denying permission

bash: /sys/class/sound/card0/reconfig: Permission denied

no didn’t try older kernel . I will try it and tell you.

This was a recommendation from Arch wiki, don’t know why it’s not working. :man_shrugging:

reverted back to


but no sound. dummy output only

OK, then let’s try this:

echo "options snd-hda-intel model=generic" | sudo tee -a /etc/modprobe.d/alsa-base.conf

This command should only be executed once as it’s adding a line to /etc/modprobe.d/alsa-base.conf in case it existed already.

Afterwards, reboot and report.

If you continue to get no sound output and still only see the Dummy Output, then you can try to replace model=generic by model=auto in that file, so edit the /etc/modprobe.d/alsa-base.conf file with a text editor (as root) and change that.

alsa-base.conf add only one line
options snd-hda-intel model=generic
i changed this to auto still no sound…

alsa-base.conf had many line when I was using pop os . I think I just created that fill and added that line .

If generic and auto are not working there is a third option which is:


Please, try this as well.

After changing. reboot.

no sound… still
only dummy output

aplay -L

    Discard all samples (playback) or generate zero samples (capture)
    Rate Converter Plugin Using Samplerate Library
    Rate Converter Plugin Using Speex Resampler
    JACK Audio Connection Kit
    Open Sound System
    PipeWire Sound Server
    PulseAudio Sound Server
    Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
    Plugin for channel upmix (4,6,8)
    Plugin for channel downmix (stereo) with a simple spacialization
    Default ALSA Output (currently PulseAudio Sound Server)
    HDA Intel HDMI, HDMI 0
    HDMI Audio Output
    HDA Intel HDMI, HDMI 1
    HDMI Audio Output
    HDA Intel HDMI, HDMI 2
    HDMI Audio Output
    HDA Intel HDMI, HDMI 3
    HDMI Audio Output
    HDA Intel HDMI
    USB Stream Output
    Front output / input
    2.1 Surround output to Front and Subwoofer speakers
    4.0 Surround output to Front and Rear speakers
    4.1 Surround output to Front, Rear and Subwoofer speakers
    5.0 Surround output to Front, Center and Rear speakers
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA Intel PCH
    USB Stream Output

Add the modprobe option suggested in dmesg to force loading of snd_hda_intel codec

echo 'options snd-intel-dspcfg dsp_driver=1' | sudo tee -a /etc/modprobe.d/alsa-hda.conf

reboot and check sudo dmesg | grep snd

if dmesg is still showing no codecs found! get more ALSA information

sudo --upload

and post the response with the link to data uploaded to alsa-project

there was no file alsa-hd.conf . i created it but still no codec found

this is the response of the alsa-info

libkmod: kmod_config_parse: /etc/modprobe.d/alsa-hda.conf line 1: ignoring bad line starting with 'options'
lspci: Unable to load libkmod resources: error -12
libkmod: kmod_config_parse: /etc/modprobe.d/alsa-hda.conf line 1: ignoring bad line starting with 'options'

there was no audio in mangaro when I was using it live as well.
don’t know if this helps.

Is this a problem of system no allowing the user to use the sound card ?

command i suggested was intended to create file /etc/modprobe.d/alsa-hda.conf
with this line of text in the file - options snd-intel-dspcfg dsp_driver=1

did you include quote marks with the text to get the error -

ignoring bad line starting with ‘options’

alsa-info data posted shows modprobe option added

snd_hda_intel: model=dual-codecs

and in dmesg

[ 7.353455] snd_hda_intel 0000:00:1b.0: no codecs found!

After that there is no sound card in kernel and alsamixer

dmesg | grep snd 

Returns nothing

need to use sudo with this command

sudo dmesg | grep snd

(simpler version of command I posted before)

If audio device is detected correctly, data should be similar to my onboard audio device, showing snd_hda_codec used for input and output connections

card 1: device 0: VT1708S Analog
[    4.258111] snd_hda_intel 0000:01:00.1: Disabling MSI
[    4.258119] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    4.339658] snd_hda_codec_via hdaudioC1D0: autoconfig for VT1708S: line_outs=4 (0x1c/0x19/0x22/0x23/0x0) type:line
[    4.339661] snd_hda_codec_via hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.339663] snd_hda_codec_via hdaudioC1D0:    hp_outs=1 (0x1d/0x0/0x0/0x0/0x0)
[    4.339665] snd_hda_codec_via hdaudioC1D0:    mono: mono_out=0x0
[    4.339666] snd_hda_codec_via hdaudioC1D0:    dig-out=0x20/0x21
[    4.339667] snd_hda_codec_via hdaudioC1D0:    inputs:
[    4.339669] snd_hda_codec_via hdaudioC1D0:      Rear Mic=0x1a
[    4.339671] snd_hda_codec_via hdaudioC1D0:      Front Mic=0x1e
[    4.339672] snd_hda_codec_via hdaudioC1D0:      Line=0x1b