No puedo actualizar normalmente mi manjaro

buenas tardes: cuando instalo actualizaciones me sale el siguiente problema:
Preparando…
Sincronizando con las bases de datos…
Actualizando AUR…
Clonando gnome-icon-theme archivos de compilación…
Generando gnome-icon-theme de información…
Comprobando gnome-icon-theme dependencias…
Clonando qpdfview archivos de compilación…
Generando qpdfview de información…
Comprobando qpdfview dependencias…
Clonando celt archivos de compilación…
Generando celt de información…
Comprobando celt dependencias…
Comprobando ceph-libs dependencias…
Resolviendo dependencias…
Comprobando conflictos entre paquetes…

Construyendo celt…
==> Creando el paquete: celt 0.11.3-6 (dom 17 dic 2023 19:21:26)
==> Comprobando dependencias mientras se ejecuta…
==> Comprobando dependencias mientras se compila…
==> Recibiendo las fuentes…
→ celt-v0.11.3.tar.bz2 ha sido encontrado
→ 010-celt-fix-tandem-test.patch ha sido encontrado
==> Validando los archivos source con sha256sums…
celt-v0.11.3.tar.bz2 … Aprobado
010-celt-fix-tandem-test.patch … Aprobado
==> Eliminando el directorio $srcdir/…
==> Extrayendo las fuentes…
→ Extrayendo celt-v0.11.3.tar.bz2 con bsdtar
==> Iniciando prepare()…
/var/tmp/pamac-build-ramiro7/celt/PKGBUILD: línea 17: patch: orden no encontrada
==> ERROR: Se produjo un fallo en prepare().
Cancelando…

alguien puede ayudarme para actualizar sin problemas?
de antemano muchas gracias
:smiley:

Punto 1: ¿Tiene estos paquetes AUR a propósito?

Punto 2: ¿Tiene los requisitos para utilizar el AUR?

Point 1 - Do you have these AUR packages (celt) on purpose?

Point 2 - Do you have the requirements to use the AUR?

1 Like

hola amigo, gracias por responder. Tu crees que deba deshabilitar AUR? con eso puedo arreglar mi problema?

quité permisos AUR y se reparó todo. Te lo agradezco mucho. :smiley:

Pero todavía tienes esos paquetes.
Si no los gestionas te encontrarás con problemas.

( especialmente ahora tendrás esos paquetes, pero no se pueden actualizar )

por favor, compruebe

pacman -Qmq
1 Like

esto obtuve:
celt
ceph-libs
dbus-x11
gcolor2
gnome-icon-theme
gnome-icon-theme-symbolic
ipw2100-fw
ipw2200-fw
js78
libsidplay
manjaro-documentation-en
manjaro-firmware
qpdfview
systemd-fsck-silent

Estos paquetes no existen en ningún repositorio y deben eliminarse:

asi

sudo pacman -Rns jz78 manjaro-documentation-en manjaro-firmware

Estos paquetes tampoco existen en ningún repositorio y deben eliminarse pero son similares a otros paquetes con los que quizás desee reemplazarlos.

asi

sudo pacman -Syu systemd dbus 

( y ipw2100-fw, ipw2200-fw son similares a ipw2x00-firmware en la AUR)
[[ porque >> pamac build ipw2x00-firmware ? no se]]


si es necesario eliminar el resto;

sudo pacman -Rns ipw2200-fw ipw2100-fw systemd-fsck-silent dbus-x11

el último no me resultó, dice lo siguiente:
sudo pacman -Rns ipw2200-fw ipw2100-fw systemd-fsck-silent dbus-x11
error: no se ha encontrado el paquete: dbus-x11

el ultimo es solo para el resto (no se que existe).
~

 sudo pacman -Rns ipw2200-fw ipw2100-fw systemd-fsck-silent
1 Like

resultó perfecto!!! muchas gracias :smiley:

de nada. uno/dos mas… por si acaso.

sudo mkinitcpio -P
sudo update-grub

(estos reconstruirán el disco RAM inicial y actualizarán el grub)

1 Like

resultó, muchas gracias maestro :smiley: