No puedo actualizar el sistema

  • OS: Manjaro Linux x86_64
  • Host: 20351 Lenovo G50-70
  • Kernel: 5.10.42-1-MANJARO
  • DE: Plasma
  • WM: KWin
  • CPU: Intel i7-4500U (4) @ 3.000GHz
  • GPU: Intel Haswell-ULT

Sencillamente, cuando intento actualizar me sale esto:

:: Sincronizando las bases de datos de los paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
 multilib está actualizado
:: Iniciando actualización completa del sistema...
:: ¿Remplazar pamac-common con extra/libpamac?  [S/n] 
resolviendo dependencias...
buscando conflictos entre paquetes...
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: instalando pacman (6.0.0-1) se rompe la dependencia con «pacman<5.3», necesaria para el paquete package-query

Hola!

No necesitas tener package-query ,lo puedes eliminar del sistema.

sudo pacman -Rdd package-query

Despues deberias poder actualizar todo.

Es una dependencia de yaourt

Yaourt ya no esta recibiendo actualizaciones, y tiene otros problemas con la seguridad del sistema. Recommendo usar Pamac o Yay.

¿Entonces podré seguir usando los repos no oficiales mediante pamac o yay como hacía con yaourt?

Si. Alomejor tienes que prender AUR support en Pamac, pero todo lo que haces con yaourt lo puedes hacer con Yay o Pamac.

Genial, muchas gracias :smiley:

Si estabas interesado, yaourt no ha recibido ningun update desde 2017: GitHub - archlinuxfr/yaourt: [unmaintained] A Pacman frontend with more features and AUR support

No esta en español, pero como usar Pamac se encuentra aqui: Pamac - Manjaro

1 Like