No plasma panels when booting with external monitor


I have a fujitsu notebook with intel gpu. When I boot it with external monitor, after logging in my desktop loads, but I can see only wallpaper and icons. No panels load. I can run only things from desktop or using alt+f2.
Rebooing doesn’t help, but if I diconnect display port and boot computer with built-in display, all panels appear as they should and remain there after plugging external display till next reboot.

Where should I look for logs?

Welcome to the Forum!

I don’t think KDE adds panels to external displays automatically; I certainly had to add panels to mine. Panels are configured on a per-monitor basis as far as I’m aware.

Hi. Thx for welcome :slight_smile: .

I thought so as well that my main screen is interpreted as additional one and I tried to add panels. I could choose an option from context menu, but nothing happened. Until I rebooted with display disconnected. Then I had a lot of panels literally everywhere :slight_smile: and had to remove them back. This prove me that a display I see is the one with panels, but panels are just not drawn for unknown reason. I have no clue which component is responsible for them and where should I look for any logs regarding failures in drawing them.

I forgot to mention that when I created additional panels, these always appeared on the primary monitor & needed to be dragged to where I wanted them, just in case you overlooked this. :wink:

I use two screens as well. Albeit permanently, so I don’t plug the in and remove them the whole time, like OP here. I can confirm that on thee first startup right after installation, there were no panels on the secondary monitor. I even had to turn the monitors around, swap them. (Probably because of thee HDMI taking priority over the DVI.)

My recommendatioon, in your case whyere you sometimes remove the external monitor, would bee to write a small scipt, that uou can set to run at startu[, to check if the monitor is connected and if so, create the panrls. In psudocode:

if($external_monitor is $connected) {
    // Set all the options for the monitor:
    // Create the panels
    // Set the background

I hope this helps.

I need to work on being more specific :smiley:

I want to work only on my external, big screen. I don’t want to use built-in screen. But when I boot my laptop with big, external screen only (with closed lid), I have no panels in plasma. What do I do wrong?

If you drag the external monitor (in Display Configuration) to the left of the laptop display, do the panels move to it? … If you don’t use the built-in display, also try setting the monitor as Primary and disabling the built-in screen.

Closing the lid usually just turns the backlight off rather than disabling that display.

That I didn’t know, thank you.

I was about to suggest setting the required one as primary. Because, since it’s plugged in, it will always be used as secondary, and thus temporary.

Disabling the one not used might also work, but I’m guessing disabling it isn’t wished.

Thanks for your replies. I think, while checking hints from BG405 I found a workaround that works for me.

When I turn laptop on I keep the lid open and wait till I login. Panels are there (fun fact: without icons). Then I close the lid, kde registers internal display “disconnection” (because built-in screen disappears from settings panel and layout preview), blinks once, icons appear and I have a single external display with panels.
@BG405 - external display is setup as primary, but I can’t move it to the left, because it’s the only one, when lid is closed.

Neverthless - issue is “resolved” - I can use my computer now…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.