No passwordless login with solokey u2f and Manjaro Gnome


I would say these two are relevant, the first belongs to some initialising of a fido key…but at the moment I have no idea…;-(

and maybe this helps…

#systemctl status gdm.service

Nov 08 07:48:29 robo-manjaro systemd[1]: Starting GNOME Display Manager…
Nov 08 07:48:29 robo-manjaro systemd[1]: Started GNOME Display Manager.
Nov 08 07:48:41 robo-manjaro gdm-password][1305]: gkr-pam: unable to locate daemon control file
Nov 08 07:48:41 robo-manjaro gdm-password][1305]: gkr-pam: stashed password to try later in open session
Nov 08 07:48:41 robo-manjaro gdm-password][1305]: pam_systemd_home(gdm-password:account): systemd-homed is not availabl>
Nov 08 07:48:41 robo-manjaro gdm-password][1305]: pam_unix(gdm-password:session): session opened for user robo(uid=1000>
Nov 08 07:48:41 robo-manjaro gdm-password][1305]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
Nov 08 07:48:46 robo-manjaro gdm[525]: Gdm: Child process -867 was already dead.

thanks for support!

if I change gdm-password to:

auth sufficient nouserok origin=pam://robo-manjaro appid=pam://robo-manjaro
auth include system-local-login
auth optional
account include system-local-login
password include system-local-login
password optional use_authtok
session include system-local-login
session optional auto_start

then I can login without a password even when the solo is not insert, just by pressing space on the start login user…

I don’t have this group.

The start login user has a password set and autologin disabled right? Have you tried it without nouserok?

yes, without “nouserok” its normal procedure with login.

see udev


If the key is not inserted when the login screen pops up it should default to password. At least on my machine if I enter a wrong password the password field disappears and the button press of the Solo is expected. Also does sudo still want the password with your current configuration?

It says only older versions need the group plugdev.

I also have an unrelated issue with my install so I am going to make a new manjaro install today and see if the setup works on my end with the link you provided.

I have removed my 70-solokeys-access.rules and the still works. And no more error messages in systemctl for udev
but no sudo pw or login pw with the solo…

yes, still need to enter the pw

Hm I just tried it on a new install with Xfce (lightdm) and sudo config and both worked immediately.
I just had to install pam-u2f and create the file ~/.config/Yubico/u2f_keys like mentioned in your link and add the line provided by the tutorial.

And I unfortunately don’t have any idea what could be the problem on your end then. :confused:

maybe I ll give him a shot and try lightdm again from scratch…
Thanks for the efforts…

Do you have the file: /etc/pam.conf ?!

No I don’t have a pam.conf. Sorry for the late reply I didn’t have access to my PC.