'No packages' in package manager on testing

Hi
I am on a PinebookPro and switched to branch testing a few days ago. Since then, the package manager says 'no package found' when browsing by category. Installing new packages via pamac and pacman works, as updating does.
Any ideas what might be wrong with package manager?

Did you resync the databases afterwards with:
sudo pacman-mirrors -g && sudo pacman -Syyu

Of course, multiple times! But now, after looking it closely, I see this:
Immediately after

pacman-mirrors -b testing

all the paths in /etc/pacman.d/mirrorlist contain testing. eg "Server = http://manjaroarm.mirrors.lavatech.top/testing/$repo/$arch"

but in /etc/pacman-mirrors.conf there is "Branch=stable"

when calling "pacman-mirrors -g" it queries the stable repositories and afterwards the mirrorlist contains paths with 'stable' instead of 'testing'.

I will now edit pacman-mirrors.conf by hand and see what happens....

Yeah, you only changed branch temporarily with pacman-mirror -b $BRANCH.
To do a permanent change you edit the pacman-mirrors.conf. :slight_smile:

After edit, pacman queries testing repositories. So that is fixed.
Package manager still says "no package found"

I assume you have also made a reboot since?

Does it only happen in the Categories section or also in the Repitory and Installed sections?

Yes rebooted!
Everything else shows a list
check:
Installed .... OK
Browse by Groups .... OK
Browse by Repositories ...OK
Browse by Categories ... NOT OK
Search.. OK

Okay. I just tried on my Pinebook Pro.

Mine shows the packages in the catagories just fine.

So I can't replicate your issue. Sorry, can't help. :frowning:

EDIT: Just updated on testing branch. I have the same issue now.

I think it could be related to appstream-data.

I could have a look into it. I'm familiar with Qt, but I never worked on a distribution. So if you help me with where to get the sources and maybe later how to submit a fix I could do a bit of work. After all, I'm
in quarantine over here! BTW, I'm on the manjaro-arm IRC, too.

It's appstream data. Quote from [Stable Update] 2020-03-24 - Kernels, KDE Frameworks 5.68, Gnome 3.36, LibreOffice 6.4.2

Where to get it from? There is no archlinux-appstream-data repository on github. (Sorry for asking stupid questions. I'm absolutely new to this)

We get it from Arch Linux ARM, which in turn gets it from Arch Linux.

https://archlinuxarm.org/packages/any/archlinux-appstream-data

Well, we fixed it on Manjaro-x64. @Strit maybe use ours for now as overlay.

Okay. Just pushed it out to all branches.

Do you have a PKGBUILD, so I can see the fix?

1 Like

Synced on testing. got the package. Categories list is populated again.
Thanks to all!

1 Like

Forum kindly sponsored by