No packages found

Fresh installation

journalctl -x -p3 -b1                                                                                                        
-- Logs begin at Sun 2020-11-22 10:42:28 IST, end at Sun 2020-11-22 15:40:19 IST. --
Nov 22 10:42:28 manjaro kernel: platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0xfed40fff]
Nov 22 10:42:28 manjaro kernel: acpi MSFT0101:00: platform device creation failed: -16
Nov 22 10:42:31 manjaro kernel: snd_hda_intel 0000:01:00.1: no codecs found!
Nov 22 10:43:09 manjaro kwin_x11[931]: kwin_xkbcommon: XKB: couldn't find a Compose file for locale "en_IN"
Nov 22 10:43:13 manjaro pulseaudio[992]: Failed to find a working profile.
Nov 22 10:43:13 manjaro pulseaudio[992]: Failed to load module "module-alsa-card" (argument: "device_id="1" name="pci-0000_01_00.1">
Nov 22 11:16:09 manjaro systemd-coredump[7045]: Failed to send coredump datagram: Connection reset by peer
Nov 22 11:16:09 manjaro kglobalaccel5[7072]: This application failed to start because no Qt platform plugin could be initialized. R>
                                             
                                             Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, min>
Nov 22 11:16:09 manjaro systemd-coredump[7086]: Failed to connect to coredump service: Connection refused
Nov 22 11:16:09 manjaro systemd[869]: Failed to start KDE Global Shortcuts Server.
░░ Subject: A start job for unit UNIT has failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ A start job for unit UNIT has finished with a failure.
░░ 
░░ The job identifier is 407 and the job result is failed.
Nov 22 11:16:09 manjaro pulseaudio[7073]: Failed to find a working profile.
Nov 22 11:16:09 manjaro pulseaudio[7073]: Failed to load module "module-alsa-card" (argument: "device_id="1" name="pci-0000_01_00.1>
Nov 22 11:16:10 manjaro pulseaudio[7073]: Unable to contact D-Bus session bus: org.freedesktop.DBus.Error.NoReply: Did not receive >
Nov 22 11:16:10 manjaro pulseaudio[7073]: Failed to load module "module-jackdbus-detect" (argument: "channels=2"): initialization f>
Nov 22 11:16:10 manjaro pulseaudio[7073]: Failed to find a working profile.
Nov 22 11:16:10 manjaro pulseaudio[7073]: Failed to load module "module-alsa-card" (argument: "device_id="1" name="pci-0000_01_00.1>
Nov 22 11:16:16 manjaro kernel: watchdog: watchdog0: watchdog did not stop!

Refresh the database from the Pamac Menu, or run from terminal:
sudo pacman-mirrors -f && sudo pacman -Syyu

Already tried that and also reinstalling pamac

What was the output of the terminal command?

Are you on wayland session?

X11 session

Querying mirror list

Mirror list generated and saved

sync package databases

I can search and install packages. It’s just that when i launch pamac i get no packages found.

I understand. Sometimes it takes a while until the database has been read the first time. It depends on your HDD. Sometimes i have also this issue, but after first run, it just works.

It’s not just the first run, i have installed several applications and rebooted couple of times.
It’s not a big issue as i use pacman for installation and updates. Pamac GUI i use for searching and that’s working fine.

Do you launch it from the icon tray or from the menu? If from tray, are you using the older version pamac-tray-appindicator or the new one pamac-tray-icon-plasma ?

From menu or from icon tray the result is same.
I’m using pamac-tray-icon-plasma.