No option to enable AUR in Pamac after new install

Before I had Manjaro 21.2.3 XFCE(feb 2022)
I formated it and installed the new Manjaro 21.3.1

In the new pamac(10.4.1), I discovered no AUR in third party.
As I want to have:
webp-pixbuf-loader for webp support in Thunar

I though ok, they want us to move to FlatPac, which I never used, let’s try.
I successfully installed XnViewMP(flatpac)
But then I realized it seems a sandbox system and I can not access the directory, I can right-click open an image and select XnViewMP but can only view that very one image, no others.
However, with XnConvert I can select a folder on my hdd, but the output is again in some sandbox.

What’s the solution to have XnViewMP and others accesing in read & write my hdd?

I suppose it must be possible with FlatPac, otherwise AUR in command line:


Have you checked that you have ‘Software Mode’ disabled in the menu?

pamac build <package_name>

1 aur/xnviewmp 1.00-1 [+286 ~0.97]
An efficient multimedia viewer, browser and converter.

xnviewmp is available in AUR. Open Pamac and look where to enable AUR in the settings…

Moderator edit: removed useless images

Hi @artofit,

Firstly, you didn’t have to reinstall Manjaro. Keeping it up-to-date is enough to ensure it’s running all the latest packages.

Secondly, since you reinstalled Manjaro, AUR support is probably disabled in Pamac. This can be enabled in 1 of two ways:

  1. The GUI method. That I never use and have no idea where to set it.

  2. The terminal/text-only/non-gui method:

  • Open /etc/pamac.conf for editing using sudo:
sudo nano /etc/pamac.conf
  • Find the line:

And remove the # in front, changing it to:

  1. Save, Ctrl+OY, and exit, Ctrl + X

  2. Refresh you databases:

pamac upgrade --force-refresh

And it should be set.

Hope this helps!

1 Like

No AUR for me with Pamac 10.4.1-1

Moderator edit: removed useless images

Done, no AUR in 10.4.1-1

Do you have libpamac installed ?

Pretty sure it should be installed by default

1 Like

Show this window…
If Pamac doesn’t show AUR there, then OP seriously messed it up.

Ben, which pamac version do you have?

10.4.1-1 - up to date on Stable branch.

Ok, try a new tack.

Open a terminal, and do pamac install xnviewmp

I get this:

❯ pamac install xnviewmp
Warning: xnviewmp is only available from AUR
Checking xnviewmp dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  xnviewmp  1.00-1    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] 

Type ‘y’ and it should work.

Now again, in the terminal, you can also do: sudo mousepad /etc/pamac.conf

Find the following line:

## Allow Pamac to search and install packages from AUR:

Ensure EnableAUR is not commented out - this is for the GUI ‘Add/Remove’ program.

it works but I really wonder how comes that “my” is different that yours !
Also Manjaro XFCE 21.3.2?
Fresh installed?

Are you sure you don’t have ‘Software Mode’ enabled?


1 Like

Wow, that takes all the results and leaves only Flatpak!!!

What’s the point of this option? Shouldn’t it be removed?

I have absolutely no idea, but it does confuse a lot of people when they can’t find the AUR settings because it is enabled.

Use this command to ensure Software Mode is disabled

sed -i 's/software_mode = true/software_mode = false/g' ~/.config/pamac/config

and this to turn on AUR support

sudo sed -i '/EnableAUR/s/^#//g' /etc/pamac.conf

After some updates and manip I have the same look and feel of the usual pamac.
How? I don’t know.

Thanks for helping

I edited your topic title as it was completely nonsensical and you presented an XY Problem instead of actually asking about what your problem was.

webp-pixbuf-loader is available in the community repo, nothing to do with the AUR.

You answered your own question. :wink:

Always make sure you’re up to date and reboot before creating a support topic. If you had done so, you would have saved yourself time as well as the time and effort of everyone that responded here.

:information_source: If English is not your first language, you have the option to post in your native language in the #languages area of the forum.

:information_source: Marking your own reply as the solution after someone else gave you information to solve your issue is selfish and rude to those who volunteered their time to help you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.