No nvidia drivers work after last update

I updated recently and after reboot the login screen (gdm) wouldn’t show. I was able to access the TTY and so I guessed it was an nvidia driver issue. At first I had nonfree 440 installed, so I updated with the mhwd -a command but I got some errors. I don’t remember what the errors were but to clear them I just removed 440 (also with mhwd) and then mhwd -a ran and without errors and installed 455. Rebooted after it finished and it still didn’t solve the issue. So I removed 455 and installed 450, still no login screen. I tried to run startx and there was an error that said something like “failed to connect to X server” (sorry I don’t have exact wording, I was doing all of this on TTY and it’s a couple of reboots later now).

So I removed 450 and now I am logged in with nouveau. So everything works perfectly with free drivers. I have no idea what is wrong with the other nvidia drivers. This is like the 3rd time this has happened after an update. First couple of times it was because the kernel updated and I just had to upgrade the nvidia driver, but for some reason that is not working this time.

What could I be doing wrong here?

Same issue for me, exept I’m using lightdm and xfce. So it seems to be a driver problem?
The exact error report in Xorg.log is “failed to initialize the nvidia kernel module”
What is weird is: when I try to come back to the previous working configuration (driver 440 through mhwd and linux54-rt) it doesn’t seem’s to work anymore.

And nouveau driver works well.

Personally I want to use nvidia driver 450 which is compatible with my gpu if I refer to nvidia website


is the Kernel (5.6.19-2) written in your Profile the used one? If you had update the Kernel to 5.9 the problem could be there. Please look if the package “opencl-nvidia-455xx” is installed. If yes deinstall it and try again.

With Kernel 5.9 there are licence issues for some external modules. In fact of nvidia there are problems with “Cuda” and “opencl”.

I also had problems while updating to kernel 5.9 with the nvidia driver. So I bootet with kernel 5.8 and reinstalled nvidia-455 without opencl. That works for me.

I hope it could help you. :slightly_smiling_face: