No nvidia drivers = no correct resolution and blinking screen / nvidia drivers = hidpi bug

I recently migrated to Manjaro using the architect .iso and installed the kde-plasma interface.

I have nothing to complain about the distribution if not for this problem I face:

If I install the Nvidia proprietary driver the entire screen composition is broken (I believe it is a problem involving dpi and edid although I’m not sure) and if I do not install it I cannot make my secondary monitor work at the correct resolution without blinking.

if i install the nvidia driver the secondary monitor works at its native resolution and refresh rate, and using Option UseEdidDpi False and Option DPI 96 x 96 partially solves the dpi-scale-composition problem

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  2. There is an issue with Hi-DPI screens and if the difference between the internal monitor and external monitor is too high, the workaround is to change the offending display’s resolution to something that works. :sob:
    For this, we need the output to xrandr to calculate what the “ideal” resolution is for both screens.

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

1 Like

The inxi --admin --verbosity=7 --filter --no-host --width output is:

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=00a8657b-305d-4f58-b85d-2ef467efc710 rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
  Mobo: ASUSTeK model: Z97-PRO GAMER v: Rev X.0x serial: <filter> 
  UEFI: American Megatrends v: 2203 date: 02/26/2016 
Memory:
  RAM: total: 7.72 GiB used: 1.94 GiB (25.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 
  L2 cache: 8192 KiB bogomips: 57599 
  Speed: 2614 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 2948 2: 3037 
  3: 3282 4: 3041 5: 3151 6: 2958 7: 3098 8: 3016 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
  sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] vendor: Micro-Star MSI 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1381 
  Display: x11 server: X. Org 1.20.9 compositor: kwin_x11 driver: nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3288x1080 s-dpi: 96 s-size: 869x285mm (34.2x11.2") 
  s-diag: 915mm (36") 
  Monitor-1: VGA-1 res: 1024x768 hz: 60 
  Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 305 size: 160x90mm (6.3x3.5") 
  diag: 184mm (7.2") 
  OpenGL: renderer: NV117 v: 4.3 Mesa 20.1.8 direct render: Yes 
Audio:
  Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8ca0 
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 10de:0fbc 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:15a1 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 1.02 TiB used: 10.62 GiB (1.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: SanDisk model: SDSSDA120G size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 00RL scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00BN5A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 111.69 GiB size: 109.44 GiB (97.98%) 
  used: 10.62 GiB (9.7%) fs: ext4 dev: /dev/sda2 label: N/A 
  uuid: 00a8657b-305d-4f58-b85d-2ef467efc710 
  ID-2: /boot/efi raw size: 100.0 MiB size: 98.4 MiB (98.45%) 
  used: 150 KiB (0.1%) fs: vfat dev: /dev/sda1 label: N/A uuid: F41B-2C87 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/sdb1 size: 465.66 GiB fs: ntfs label: HDD uuid: 2BF36B537E716E4B 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 1-1:2 info: Intel ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:8009 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 2-13:2 info: Logitech M105 Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 046d:c077 
  Hub: 2-14:3 info: Genesys Logic Hub ports: 3 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05e3:0608 
  Device-1: 2-14.1:4 info: Cooler Master type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 1.1 speed: 12 Mb/s 
  chip ID: 2516:0002 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 3-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s 
  chip ID: 8087:8001 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 39 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 900 
Info:
  Processes: 213 Uptime: 8h 38m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: pacman: 1191 lib: 317 flatpak: 0 Shell: fish v: 3.1.2 
  running in: konsole inxi: 3.1.05

My primary monitor is a samsung P2270HN and my secondary monitor is a W1943C, when I install the Nvidia driver the secondary resolution is 1368x768 and it works perfectly … But it breaks the screen composition.

  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
    

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    (as that makes our life much easier so you get helped more quickly and efficiently)

  2. No need to do anything right now as I’m an editor here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. you forgot the xrandr output: that gives resolution and size…

:+1:

at the moment I’m not using the monitor at the resolution that makes it blink

xrandr output:

DVI-D-1 disconnected (normal left inverted right x axis y axis)
VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
HDMI-1 connected primary 1920x1080+1368+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    60.00    50.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08```

If your VGA monitor is a 17" monitor (those don’t give sizes) then 1920x1080 is a good compromise, but 1400x1050 would be better:

https://upload.wikimedia.org/wikipedia/commons/6/63/Vector_Video_Standards.svg

If you’re interested we can go ahead or you just keep what you have already…

:grin:

on my left (VGA-1)W1943C 18,5’’ 1360 x 768 (runs better on 1368x768) @ 60Hz h 30 ~ 61 kHz v 56 ~ 75 Hz
right in front of me (HDMI-1) P2270HN 1920x1080 @ 60

both 16:9

I’m currently using the free driver with the secondary monitor in a 4: 3 resolution so that it doesn’t blink

Will it only support 1368x768 with nvidia drivers?
Is there a way to save the resolution setting (modeset) of the nvidia driver and use it on the free drive?
How is workaround to solve the dpi problem you said?

I don’t think your HDMI monitor is

What’s the real size???

So basically what you do is to look in the Video standards comparison chart and take resolutions that would give you the same size square on both monitors at the highest possible refresh rate and that’s it!

The solution is independent of graphics card / driver and gives the best *consistent user experience; (Yes, you don’t use both monitors at the highest resolution, but it’s more comfortable to work with until you can afford identical monitors)

:+1:

HDMI-1 (P2270HN) 48cmX27cm screen
VGA-1 (W1943C) 41cmX23,3cm screen if I’m not mistaken

The VGA screen is the limiting factor and has

  • 1024x768 60.00 Hz
  • 41cmX23,3cm
  • 16:9
  • 2.4dpmm

The HDMI screen has

  • 48cmX27cm
  • 16:9

So 1024/41*48=1199, so the following 2 resolutions on your HDMI screen are best when both monitors are standing next to one another:

  • 1280x800 59.91Hz
  • 1152x864 75.00Hz

Up to you to see which of those 2 feels best as there is exact match.

:+1:

I am very grateful for your attention. :blush:

But i am curious and didn’t understand exactly what’s going on, could you please explain to me? On Linux Mint Cinnamon with Nvidia’s proprietary drivers I can use the 2 monitors in their native resolution (I haven’t tested the Manjaro with Cinnamon yet).

Why can’t I change my secondary screen to a native resolution using KDE + Noveau?
For what reason if the two screens are at their native resolutions with the proprietary drivers the system breaks KDE composition?
Is it a problem with X? Video card drivers?
There is no way to make the system work by forcing a DPI or something?
I was a Linux Mint user previously and I loved using Manjaro, I intend to stay here xD But I would like to have my 2 screens in their native resolution (would even be inclined to buy a new video card if it solved the problem).

That’s what you’re doing right now and will also be doing when you use the resolutions I gave you above:

VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
HDMI-1 connected primary 1920x1080+1368+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98  

These are their native resolutions, unless I don’t understand what you’re talking about. :thinking:

Please explain because whatever xrandr gives as output is native. Are you wanting to add custom resolutions???

:upside_down_face:

The situation is as follows:

If I use Windows or Linux Mint Cinnamon with proprietary Nvidia drivers the Samsung monitor remains at 1920x1080 but the LG monitor on my left changes to 1368x768 (the native resolution).

At the moment I have 2 choices: Continue with the perfect screen composition but with the monitor on the left in a broken resolution (both of them looks horrible outside the native resolution), or install the proprietary Nvidia driver and leave my monitor at 1368x768 and break the KDE screen composition.

Using those settings to force the dpi partially solve the problem (but not completely and some things like the login screen are broken, resized icons is horrible too).

I’ve tried using addmode to try to put the monitor on the left at its native resolution(1024x768>1368x768), it didn’t work with free driver (the proprietary driver already goes automatically).

I was wondering if there is a way to save the proprietary driver’s “modeset” settings for the secondary monitor to use with noveau or if there is a way to force the dpi or solve the broken composition problem on the proprietary driver.

This broken composition error seems to happen only with KDE (even in other distributions).

What I didn’t understand is why KDE works perfectly with noveau, however noveau does not recognize the resolution of my secondary screen correctly but if I install the proprietary driver the screen will switch to the native resolution but KDE will break.


setting fonts dpi to 96 + scale 125%

Which exact command?

What happens?

I think I partially understand your problem now. Don’t forget that nouveau is open source so this is probably a bug: if it detects a VGA port, it goes to VGA modes only instead of SVGA modes. Have you tried the standard framebuffer driver if you don’t game? (I.e. video-linux or video-modesetting instead of nouveau or nVidia?

:thinking:

cvt 1368x768
gtf 1368x768
xrandr --newmode
xrandr --addmode VGA-1…
the ones to set custom resolution and stuff

as in the image above, all elements start to flash and are badly sized.

The thing is… KDE with the noveau works flawlessly here! :drooling_face:

If I could save the timings / modeset used by the nvidia driver and use them just to keep the secondary monitor at its native resolution in the modeset-driver it would be very good.

edit:

Now that I have installed the proprietary driver the monitor is in its native resolution but KDE is still broken and I will probably have to reinstall the system again to resolve (if you zoom in on the screen elements, you can notice some flaws between them) …

My initial idea was to save the timings somewhere as it is now, reinstall the system without installing the proprietary drivers and just use the native resolution’s timings… I have no idea what this KDE incompatibility with nvidia might be, wayland :rofl:?

That’s good: you’re cot copying from a random website… (Sorry, was just checking)

It shouldn’t be!

What’s the output of

loginctl show-session $(loginctl | grep $USER | awk '{print $1}') --property Type

Your :eyes: are better than mine! I can’t see anything wrong!

Desculpe, but I’m throwing my hands in the air now.

:man_shrugging: :sob:

Type=x11

LMAOs2

Now i realized something… Isn’t just KDE interface but vlc too… Qt bug or something?

lmso

How do i set the real physical size of the screens? How do i get the “modeline”?

No wayland! :slight_smile:

Which Theme are you using? (Looks like a theme bug: try Breeze2) If that doesn’t resolve the issue: create a new user and log in there and see if it happens there too.

How to change to Wayland?

Any theme, and it’s not just the theme, vlc and gimp are broken too

same but no 75hz option here, if the global scale is 100% everything gets messed up like the screen above (too big). putting on 125% makes it smaller (yeah… i know)

Don’t! It’s rubbish! still under development!

Also Breeze2, the Manjaro theme?

How about that one?

:grin: