No media players, or media related packages starting

Hi, I am running Manjaro XFCE with Kernel 5.13.19. Recently I was trying out different YouTube players, namely, MotionBox, MiniTube. After installing them, my VLC player, gThumb etc. stopped playing any video. VLC started playing only audio, no video along with it. SimpleVideoRecorder stopped initializing.

I understand some video dependency got uninstalled or broken. I remember installing Gstreamer plugin bad/ugly, uninstalled them but nothing. Uninstalled VLC, reinstalled, now VLC won’t even start. No errors. Not sure what went wrong and how to start debugging.

Note: Also installed all the necessary codecs, didn’t help.



When I run xdg-open The.Matrix.mp4, terminal says-

/usr/bin/vlc: /usr/lib/ version `GLIBC_2.34' not found (required by /usr/bin/vlc)
/usr/bin/vlc: /usr/lib/ version `GLIBC_2.34' not found (required by /usr/lib/

Welcome to the forum!

5.13 has been EOL (end-of-life) for ages already and is no longer supported. Please switch to a more recent kernel or install an LTS kernel.

Manjaro Stable is currently using glibc 2.36.

From what it looks like, you haven’t updated your system in quite a while. I suggest you do that first, and install a newer kernel. Don’t remove the old kernel until after you’ve rebooted into the newer kernel.

pamac update && sudo mhwd-kernel -i linux515

… will update your system and install kernel 5.15, which is an LTS kernel. If you are using proprietary drivers, then the above command will also pull in the matching drivers for said kernel.


@Aragorn, I don’t have enough space in my drive to do an upgrade of the whole system which caused the delay. Will be buying a new drive back things up to free up the system drive. Any workaround till then? System was fine until I tried installing the player and uninstalling some media dependency in the process, obviously unwittingly. As a workaround I am using chrome’s media player plugin which can play videos btw. Not sure if that info helps.

That’s because you are now experiencing a partial-upgrade scenario. You installed something that requires a more recent version of glibc than what your system has.

It’s your system and you do with it as you like, but we cannot offer any support for a partial-upgrade scenario, so I guess you’ll have to wait for the new drive. :man_shrugging:

You could of course try upgrading your system while cleaning out your old package cache… :arrow_down:

sudo paccache -rvk0

Then run the two commands I gave you higher up. Your used disk space should not increase too drastically.


I think it’s about time to recommend 50GB minimum for your root drive. It really depends on your use case.

Another thing that works for me is keeping root and home in separate partitions.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.