No Man's Sky on steam returns error

The game worked fine, I took a break for some months and wanted to come back recently but the game won’t run. It starts, I can see mode choosing screen, but no matter what I choose it will always fail. Before it was a black screen and only killing process would help, now it’s an error message (that tells nothing, just a code that should be given to devs while reporting a bug). All other games are working fine. Only problem is with this one.

I decided to try to experiment a little. I created a new user account, opened Steam, installed a game and… it worked. So I came back to my main account, removed Steam, deleted every Steam folder I could find, installed it again, installed a game, didn’t change anything with settings (except enabling Proton) and… error, just like before. I have no idea how to approach this. What makes a difference? I will appreciate any suggestions.

Clean you Proton prefix for this specific game maybe something went wrong during the transition between Proton versions.

To do that browse to ~/.local/share/Steam/steamapps/compatdata/ if you use the default Steam library path (adapt path if not), and rename the folder with the AppID of your Steam game (according to ProtonDB it is 275850 so rename it to 275850_old for example).
When you will start the game it will recreate a clean prefix for the game from the Proton version you use.

Also make sure you remove startup parameters from the game properties in Steam library, if you have set some to discard issues regarding wrong parameters.

If you want to use Proton-GE versions, it is highly recommended (and sometimes mandatory) to clean the prefix to start fresh so there is no issue while the prefix got updated from official Proton to the modified Proton-GE.

As I mentioned in my original post I deleted every steam folder, which also include the one in .local/share so there is nothing to clean there.

I don’t want to use Proton-GE because obviously game works without any tweaks on my computers, unfortunately not on my main account.

But your posts are not clear. As you didn’t say what folder you removed I can’t know it. Also you said

Then you said you tried on a new user

You said other games were working on your current user, so if you try other game on new account it should work too, or you meant you installed No Man’s Sky and not “a game”?

Try to give the most detailed explanation so it is clear what you have done.

I thought part of the sentence “deleted every Steam folder I could find” was clear enough. “Every” for me means all SteamLibrary folders (I had 3), .local/share/steam and .steam in home directory.

“All other games are working fine. Only problem is with this one.”. On my main account.

“I created a new user, opened Steam, installed a game and… it worked”. I didn’t install any other games because all of them are working fine on my main account. There was no point.

No Man’s Sky is “a game” and that’s what I installed. I’m not sure what You meant in that sentenced.

I’m not sure how to make it more clear. Let me try anyway:

  1. created a new user account
  2. opened Steam
  3. installed No Man’s Sky and… it worked
  4. came back to my main account
  5. removed Steam
  6. deleted every Steam folder I could find
  7. installed Steam again
  8. installed No Man’s Sky
  9. run No Man’s Sky, didn’t work

Obviously not, what if you didn’t find these folders? As I said I can’t know what you deleted, and didn’t assume you deleted them, especially with the rest of the post.

Yes, No Man’s Sky is “a game”, and so are all other games in your library. I meant exactly what I wrote, what wasn’t clear in my reply? You said “a game” and I didn’t assume it was No Man’s Sky, as to me you would have written that, like you now did.

There is probably something you have done on this current user that is conflicting with the game. Some customization, some background program, some overlay, some desktop customization, and so on, it is not easy to find it remotely.

Try to see the difference between a clean user and your current user, and go step by step, by elimination, either by adding stuff in new user, or removing things in current user until it breaks or work depending the way you go.

//EDIT: also maybe share the error message you get, even if it is “just a code”.

Did you try configuring it to use a specific version of proton? I’ve been running the game just fine on proton 6.3-6 for the last couple of days.

I’ve tried 6.3-6, 5.13-6 and 5.0-10.