No Manjaro UEFI boot entry after installation, boots directly to Windows

I repeated those steps. I am installing afresh. Because all of it seems messed up and I can’t figure out.

1 Like

After the fresh install will I have to repeat the grub restore steps again?

Maybe, maybe not. Depends if it works properly this time.

1 Like

Well, it wants to test my patience :joy: I’ll try once again.


I have mounted the manjaro partition and the boot partition and now it looks like this in Gparted. Looks good? Should I proceed?
I am sorry to bug you guys but that’s the only way for me :frowning:
I went for the next step and I see this. But I can see mtools and os-prober installed in octopi.
The database error is solved, I found a way to sync mirrors.

Did it all over again, everything worked according to the guide. But I still can’t get manjaro in boot menu.
Removed the USB after shutting down and the restarted but no luck.


During installation I edited the mount point to /boot/efi and mount point of manjaro installation drive i.e sda5 in my case to “/” But booting from the live USB and launching the installer shows nothing in the mount point column.

Ofcourse not. Because it is not a “partition viewer” but an installer, so it takes it all as totally new partitions. :slight_smile:


Okay this has some details, that might help you guide me further. sda5 is manjaro installation partition and sda2 is the EFI partition.

Did you read the previous section and chroot?

I’ve used these steps many (many) times and they have worked successfully every time.

I started by installing mhwd-chroot, if that’s what you mean.


What I see is the EFI partition is not mounted, but I did mount it with mount point /boot/efi during the install.

Looking at your second screenshot above you mounted /mnt/boot but not /mnt/boot/efi inside the chroot.

(In the first screenshot you’ve got the partitions mounted in… interesting locations, which don’t tally with the terminal commands.)

Essentially, if you mounted your EFI partition /dev/sda2 as /boot then kernel files will be installed to the root of that partition and EFI files to a subdirectory /boot/efi.

If you set /dev/sda2 to mount at /boot/efi during installation then the files will be in the wrong place for that setup (likely /boot/efi/efi).

The likely solution is to mount /dev/sda2 /mnt/boot/efi during the chroot setup.

Do I need to unmount before doing that because I have already done mount /dev/sda2 /mnt/boot in chroot? Or I need to start over again?


Does this look correct to you?
I started over again and this time set the mount point of EFI to /boot
And when I click next this is what I seeScreenshot_20180402_043033

Okay so I have no idea what worked, but I created a separate EFI partition for manjaro and it did the trick for me.
I really really appreciate your effort, time & patience @maycne.sonahoz @jonathon @Strit
In the end turned out to be a good sunday for me lol.

3 Likes

This worked and it is in the wiki.

Well, I posted on the forums as a last resort after watching a tonne of youtube videos and different forums. My original issue was “grub rescue”. After I toiled for almost an entire day, I had to post it here. And in no means I did it to escape some “hardwork”.
P.S. Was a fun thread to glance through.

I already had an EFI partition, but creating a new one did the trick.

You see what you did wrong there? :wink:

(I’ve never rated YouTube as a good/reliable source of information; most of my web searches now include “-youtube”.)

Welcome to Manjaro noob_jack.
We don’t pull any punches here, that’s because we respect each other too much.
Better get used to it. Some call us toxic, but we think we’re just unpretentious. :grinning:

Cheers.

ps: if you’re still up to it…:sunglasses:

Have you tried the screen shot here first? :grin::joy:

Told you, we pull no punches. :laughing:

[Edit] - Forgot this - the main story. Sorry.

Did you mount it ? The original one? At installation? As /boot/efi?

I duckduckgoed it. Yes I mounted it. Actually my GPU burnt out playing a game ( I own a 100000 watt dell oven) which I realised later, but I was stuck in BSOD in win 10 and someone suggested me to remove everything and do a clean install, and I deleted my Linux mint partitions. Now when I attempted to live boot manjaro it would trigger grub rescue. I tried everything grub rescue but burning a DD image solved the issue.
But how the EFI partition thing worked, I still have no clue and yes I mounted it at /boot/efi. I wished this thread could be of help to some other newbie like me, but seems like this thread itself is a puzzle, coz I don’t know what solution worked. :smiley:
So I posted here for one issue and landed into another and it kept going. I am glad this forum is so active and full of good folks.

1 Like

Forum kindly sponsored by