No Manjaro UEFI boot entry after installation, boots directly to Windows

Something weird happened. I installed manjaro successfully and it asked me to reboot. Once rebooted I couldn’t see a boot menu for manjaro, all I saw is windows boot manager and the live USB.

I attempted installation again from the live USB and the screenshot shows that manjaro is already installed.

I am clueless here.

Does your computer boot in UEFI mode?
If yes, did you booted your LiveUSB in UEFI mode for your installation?

Yes it boots in both, but I remember well, I selected UEFI for installation.
I recollect during the “grub rescue” errors I did the “set prefix=(cd0)” and "root=(cd0) for the live USB, do you see a connection here?

From your screenshot, the “BIOS” label hints you boot on the LiveUSB in legacy mode. Were you in UEFI mode, the installer would install in UEFI mode, and would label “EFI” instead of “BIOS”.

At boot, select the LiveUSB entry with EFI or UEFI in its name.

Disabled legacy, selcted USB from UEFI, installed again. Same issue when I reboot after installation, I see windows boot manager and the USB drive.


This is what windows disk management shows, if that helps figure out what’s wrong. The one with 517.94GB is where I installed manjaro.

Is Secure Boot enabled in the BIOS?
If yes, what happens if you boot with Secure Boot off?

https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

Secure boot is disabled, if it is enabled I can’t boot the live USB. I am trying the guide suggested by jonathan right now.


I am at the stage highlighted in the screenshot, I do have a EFI partition but it is only 100mb, I freed up some space with gparted to allocate it to the EFI partition but I can’t expand the EFI partition more than 100mb, so is it okay to have 100mb or should I make another EFI partition?
This is what my gparted looks like.

100MB is fine. Just don’t format it. :wink:

Wow that was quick. Thanks, I’ll go forward now.

Remember it needs to be mounted as /boot/efi when installing, without formatting it.

Got it. Just finished the steps. Now I am about to reboot and see if I can see the menu. I’ll hit base in a few!


Rebooted and this is what I see :frowning:

You’ve pressed the boot options key when booting. When Manjaro installed, reboot the machine. But before it boots up, take out the USB stick.


Did that, so now I see only windows.

Btw, I followed all the steps in the guide suggested by Jonathan and then rebooted right after that. Do I need to install Manjaro again after that?

What you need to make sure, is that the fat32 partition is marked with /boot/efi as mountpoint in the Calamares installer.

Please provide a Screenshot of the partitioning section in Calamares, from just before you press Next.

Screenshot_20180402_012747
I am on it, but currently stuck here for quite a while. I’ll wait for a while and see what happens.


This is what I got. I guess the first screenshot (used Gparted for it) shows “not mounted”. Is that what you are trying to say? Also this is not a calamares installer it’s something Hakoila Installer.
Just checked the “grub restore” guide again. Seems like I missed mounting the boot partition.

It is the calamares installer. The Manjaro release is named Hakoila. The Installer is called Calamares.

1 Like

That’s kind of key if you’re missing your boot loader. :wink:

Forum kindly sponsored by Bytemark