No login window after update

Please supply this information when submitting a bug report.

  • What device are you using? RPi 3B+

  • What edition of Manjaro-ARM is installed? (eg minimal, server, etc.)

  • When did you last run updates and reboot? 2019.06.01

  • What package contains the bug? Probably sddm or qt

  • Describe the bug the best you can. What where you doing when the bug happened? I ran pacman -Syyu and let Manjaro install its updates. After reboot there was no login window

  • Any workarounds or known fixes? Nope

Hi, is it just my system that got borked after the last set of updates or has there been similar cases ? I ran pacman -Syyu and let Manjaro install its updates. After reboot there was no login window.

There were no error messages in journalctl --since=today

systemctl status grahical.target displays although there is no X running:
Loaded: loaded (/usr/lib/systemd/graphical.target; static; vendor preset: disabled)
Active: active since Sat 2019-06-01 13:11:56 EEST; 45 mins ago
Docs: man:systemd.special(7)
Jun 01 13:11:56 archlinux systemd[1]: Reached target Graphical interface

Starting sddm-greeter manually as a normal user prints:
(13:40:06.458) (II) GREETER: High-DPI autoscaling not Enabled
(13:40:06.512) (WW) GREETER: could not connect to display
(13:40:06.513) (II) GREETER: Could not load the QT platform plugin "xcb" in "" even though it was found.
(13:40:06.514) (EE) GREETER: This application failed to starts because no QT platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
Aborted (core dumped)

I reinstalled sddm but that did not help.

Any ideas ? A couple of months ago there was a similar case where sddm-greeter could not start after package update because some QT plugins were not updated also: After package update: sddm-greeter dumps core

Update: After starting my RPI 3 B+ up again after 2 days I noticed the message "system.journal corrupted or uncleanly shut down, renaming and replacing" and now the login window appeared.

So this problem probably has nothing to do with Manjaro and everything to do with filesystem corruption. I have divided my OS so that only the /boot directory is on a SD - card and the rest of the folders are on a USB disk (magnetic media).

It's possible.

There was no qt5 update this time around, so I was starting to get worried when you posted. :slight_smile:

I was mistaken: "system.journal" means systemd journal (logs), so the corruption is in the systemd log file not filesystem.

I will try again after a couple of days or maybe when a new kernel appears. Maybe I just need to reinstall my system.

By the way Manjaro-Arm is the only distro I found that has a kernel that has all common encryption modules built in. These are needed for example when using ecryptfs (Encrypting Filesystem). I can not understand why Raspbian and Ubuntu decided to disable these common necessary kernel modules. These modules are on by default on all distros for Intel platform. Maybe its because (puts tin foil hat on) because RPi has a good hardware random number generator and NSA don't want you to use one. Intel platform randomness is probably compromised already :slight_smile:

I suspect my hardware has become flaky. Same sd-card + harddisk boots to login screen with another RPi.