No Login User Icon, no TTY access, live USB cryptsetup fails. Need chroot to repair system

Hey manjaro fam,

Been making an extremely concerted effort to switch from Windows to Manjaro for gaming.

I recently got steam and nvidia drivers installed and configured proton to play a few games before shutting down. Now when I turn my computer on I have no user available to log in with Gnome.

I tried CTRL + ALT + F2-12 and none of them bring up a TTY terminal.

Now I’m trying to repair via live USB and I can’t get my luks partition mounted. I’m following the guide here from: stuck-during-boot-help-needed-to-chroot-into-encrypted-system/125640/9

sudo -i
cryptsetup -v luksOpen /dev/nvme0n1p2 cryptDrive
mount /dev/mapper/cryptDrive /mnt
manjaro-chroot /mnt

But I get an error mounting my NVME drive:

cryptsetup -v luksOpen /dev/nvme1n1p2 nvme1n1
Enter passphrase for /dev/nvme1n1p2:
device-mapper: reload ioctl on nvme1n1 (254:0) failed: Invalid Argument
Command failed with code -4 (wrong device or file specified).

I really love Gnome and made the switch to Manjaro from Ubuntu for work so I would love to learn how to debug gnome issues in more detail but it seems like something isn’t going quite right here. I’m not sure why I have no TTY access or why I can’t unlock my manjaro partition to chroot.

EDIT: Right now I’m trying to make sure dm-crypt module is available as I’m not sure what exactly is the issue with my system. So I did modprobe dm-crypt and got modprobe: FATAL: Module dm-crypt not found in directory /lib/moudles/6.1.11-1-MANJARO

You did notice that this:

cryptsetup -v luksOpen /dev/nvme0n1p2 cryptDrive

is different from this:

cryptsetup -v luksOpen /dev/nvme1n1p2 nvme1n1


but that last part is just a name - can be anything

Before you try to open the container - make sure you are targeting the correct device.

lsblk -f

Maybe you encrypted the whole system (likely, as that is what the installer does).

Okay I just tried everything again weirdly and the command is succeeding now. I still have no idea how to repair gnome but hopefully this is a step in the right direction. Here are the commands and the results I did just now:

cryptsetup -v luksOpen /dev/nvme1n1 nvme1n1
Device /dev/nvme1n1 is not a valid LUKS device.
Command failed with code -1 (wrong or missing parameters).
cryptsetup -v luksOpen /dev/nvme1n1p1 nvme1n1
Device /dev/nvme1n1p1 is not a valid LUKS device.
Command failed with code -1 (wrong or missing parameters).
cryptsetup -v luksOpen /dev/nvme1n1p2 nvme1n1
Enter passphrase for /dev/nvme1n1p2:
Key slot 0 unlocked.
Command successful.

I have no idea what happened differently this time. Maybe it was a typo? Maybe it was the grub launch parameters that were different? My USB is also not successfully booting. It says device was unable to be reached after 30 seconds. I have to unplug it, wait 10 seconds, replug it in, type exit, and then it boots the manjaro live USB session.

I was able to mount the disk and chroot and then ran pacman -Syu and downloaded updates for linux-firmware, linux-6.1.19-1, linux61-nvidia-525.89.02-11 , manjaro-gnome-settings-20230316-1 and manjaro-release-22.0.5-1 and now I get the user login option but the computer is completely frozen. Still no TTY support.

EDIT: Okay it was frozen for a couple minutes while I typed the previous edit but now it’s working again. I was able to log in. I’m going to update everything and reboot to verify things are still working.

EDIT2: It looks like my computer freezes at the gnome user select login screen for about 30 seconds now but eventually recovers and I can log into my desktop and game!

No need to try random partitions when you can just look at what is actually there before you “try” :man_shrugging:

lsblk -f

I meant I tried all the cryptsetup commands again after going back to my broken PC. I did lsblk -f and verified that only the partition /dev/nvme1n1p2 was LUKS. The other partition was FAT32.

The commands I did were identical each time which makes me think that something about my live USB installer not working might be the culprit. Or my GRUB launch parameters (proprietary vs open source drivers).

For the USB live installer issue I just followed the guide at /t/device-did-not-show-up-after-30-seconds-i-cant-install-manjaro/121381

I wonder if I should re-make the live USB installer? I don’t know how often those get upgraded.

You could try, but it should be pretty irrelevant.
You can do this procedure (open the container and then chroot) with any halfway recent linux iso - it doesn’t need to be Manjaro.
manjaro-chroot makes it easier (or arch-chroot) - but any Ubuntu or Mint or what have you will do just fine - just the chroot procedure is not so easy without the help of the manjaro-chroot tool (a couple of commands instead of just one …)

I appreciate the help and the information! I know this will probably happen again so I’m happy have some more knowledge in my back pocket to fix the issue when it does pop up again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.