No line input w/ Pipewire 3.59

Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.3 Distro: Manjaro Linux. Pipewire 3.59 w/ Session Manager. System Asus Tuf Z270 Intel I 7700.

No audio through the line input. Considering doing away with session manager and installing Wireplumber but thought I would ask to see if any others have experienced this and what resolutions might exist. Hoping to find a solution before going back into the nightmare of what is the Linux sound stack.

Are you using wireplumber as your pipewire session manager?
If not give it a try.

1 Like

Hi Robin0800
Thanks very much for the suggestion. Will try this later today and post back results.

Installed wireplumber, that uninstalled session manager. Used systemctl to enable wireplumber per the instructions from that website. Works fine just playing back audio from the system internal sources.

2 desktops and one pair of near field monitors. The monitors stay connected to system A. Lately I have been doing some audio work using Audacity on system B when A is occupied with other things. What I wanted to do was to be able to connect B’s line output to A’s line input, then open System Settings-Audio on A and raise the line input level to hear B’s output. Simple, yes? After wireplumber, A still would not see the B source. The only way I was able to get any audio from B through A and to the monitors was to open Helvum patchbay on A and manually patch the line input from B to the A line output. Other than opening the patchbay and doing it that way I have not been able to make this work so I am at a loss. While tempted to rant a bit here I executed systemctl rant --stop and systemctl rant --disable as root, before I posted this.
robin0800 thanks for the kind suggestion. I am at a bit of a loss for why something so simple is seemingly more complicated than it need be.

IMO the simplest solution for monitoring audio from 2 systems is to use a monitor controller or a line mixer for audio outputs from both systems

If additional outboard gear is not an option, there are audio controls in ALSA to monitor audio from a Line In jack using Line Out, Speaker or Headphone jack on the same audio device with zero latency

On my system the onboard audio codec has 2 ALSA controls for monitoring Line in audio

amixer --card=1 sset 'Loopback Mixing' Enabled; amixer --card=1 sset `Line` 0.0dB unmute

Hardware scans for TUF Z270 suggest onboard audio codec (ALC1220) is detected as card=0 in ALSA rather than card=1, but the audio controls have the same names: ‘Line’ and ‘Loopback Mixing’
HW probe of ASUSTek TUF Z270 MARK 1 Desktop Computer #dc1aa01b01: amixer

I suggest you check ALSA settings for card 0 before making changes

amixer --card=0

This command should turn on Loopback mixing and Line monitor

amixer -c0 sset 'Loopback Mixing' Enabled; amixer -c0 sset `Line` 0.0dB unmute

Simpler command should be enough to turn audio monitoring off

amixer -c0 sset 'Loopback Mixing' Disabled

Implementing audio loopbacks in software sound servers (PulseAudio, JACK or PipeWire) is usually more complex; always adds latency to the Line in audio stream and might not work consistently to maintain audio settings after system suspend/hibernation/restart

1 Like

Excellent suggestions deeply appreciated. Will investigate this and post back. Many thanks for your efforts to help me solve this.
In 2011-2012 my playroom had 3 desktops and a bunch of amateur radio gear. Aside from the grounding and shielding I had to do for rf, I ended up using external mixers and a patchbay for audio routing. That may be what I do here. Again many thanks.

Try left clicking on the speaker icon in the taskbar and select the correct input, as it doesn’t always default properly.

1 Like

hi tnaser4

Thanks for this. Have resolved it by using an external mixer for both machines.

My apologies for not coming back here and marking this solved. Regards to all.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.