No internet available after hibernation

Same issue with 5.10, 5.17, and my current kernel, 5.15.

and if you put your pc into sleep instead of hybernating, and after waking up from sleep, do you have internet?

Yep, it works fine after sleeping/waking.

Additional data point: I tested my wireless just to see what happens. No wifi option, no option to connect; then I found Network Interfaces. Turns out that only the first two interfaces on the left (address: lo) remain after hibernation; the other four (which look like my wifi ones) disappear.

Could this be related, or should I open a separate thread for this?

no let it here, its related to your issue… and did you try to disable ipv6? disable it on all networks, and try hibernate

OK, will try that.

Another interesting data point: I tried this answer on how to fix wifi disappearing after hibernate. It caused the wifi to remain/persist after hibernate (yay!), but my computer never shut down (restarted and it hanged on something in the terminal list of shutdown events, had to press/hold power button).

Still, it might be useful to know.

and which of those solutions did you try, the uninstalling, or mac address… you should have waited for cca 3 minutes for it to shutdown

I tried the script block: adding wifi.scan-rand-mac-address=no to that file and then running systemctl .... I waited more than three minutes (restart is usually instantaneous for me).

Disabling ipv6 seems to help: I can see both my wifi and wired connections appear after resuming from hibernate. The wifi seems to connect (but doesn’t work - I have a pre-existing wifi/router problem). Same problem with wired (connects but “no internet”).

try installing tlpui and check settings under network

Here are the settings, I can’t figure out what they mean though (googling turned up little info).

the wifi_pwr_on_bat means power saving mode on battery is enabled, disable it, try the hibernation, if still no internet disable wol_disable and try hibernate, if also no internet keep disabled the wol and enable again the power on battery, and try hibernate

Thanks for the explanation. If I’m understanding you correctly, here’s what I tried; on/off means the toggle is on (blue) or off (grey).


Same result, no internet.

so can you uncheck all of those check marks, click save, and reboot, and check again hibernation

Already tried it - that’s the third test-case on my list

if i understand it correctly, you unchecked the blue checks on the left side? if yes and it still didnt worked, so its probably not related to power saving…

Yes - all three checks show grey / left side / off, and still the issue persists.

so try completely uninstalling the tlp, like mentioned in the post above, reboot and check again

Sorry, I didn’t see that you mentioned uninstall. I actually had to install TLP the first time. Uninstalled, same problem.

please open a terminal and run these 2 commands:

sudo rfkill unblock all
sudo systemctl restart NetworkManager

any changes ?

Did you mean hibernate and then run it when you see the problem? I did that, and no changes. (The internet disconnected and attempted to reconnect, with the same issue.)