No internet access while connected to Mullvad VPN

I have your same problem. I reached out to mullvad support through their app and they said to do this. I’m also using OpenVPN not the Automatic. It worked for me.

sudo systemctl enable systemd-resolved

sudo ln -sf /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf

sudo systemctl start systemd-resolved

sudo systemctl restart NetworkManager