No image previews in ranger with manjaro-ranger-settings

Hi, Community!

In Manjaro i3 the ranger file manager is provided by the manjaro-ranger-settings package, which also comes with python-ueberzug instead of w3mimgdisplay.

However, I have no luck getting image previews in ranger with the default configuration.

Has anybody experienced a similar problem?

Which terminal?

rxvt-unicode-256color

Let me test. BRB.

:edit: Working here:


What do you have in ~/.config/ranger/rc.conf:

set preview_images_method ueberzug

I use kitty.

I use alacritty

1 Like

Sorry for the late reply,

Here's my ~/.config/ranger/rc.conf:

set show_hidden true
set preview_images true
set preview_images_method ueberzug
set colorscheme zenburn
set draw_borders both

Also, I've found three different rc.conf files:

/etc/skel/.config/ranger/rc.conf
/usr/share/doc/ranger/config/rc.conf
/usr/lib/python3.8/site-packages/ranger/config/rc.conf

(Actually, the last two are identical, but the first one is different.)

Which one of them should be in use?


UPD

I synced my ~/.config/ranger to /etc/skel/.config/ranger, but still no luck :frowning:

I just tested ranger booting the latest i3 edition ISO image (18.1.5 - 191229) and can confirm that image previews don't work when using ueberzug as the preview method.

You can

1
use w3m as the preview method - in your ~/.config/ranger/rc.conf file add

set preview_images_method w3m

and restart ranger (the package w3m is needed for this to work)

or

2
install ranger-git from the AUR (replacing ranger in your system) and use ueberzug for image previews.

4 Likes

Thanks, replacing ranger with ranger-git from the AUR solved the problem. I hope the Manjaro version of ranger gets updated soon, so I can switch back.

1 Like

Thanks for the heads up. I'll look into it when I get the opportunity.

2 Likes

Looks like I have -git installed :blush:

I don't know if you remember @Chrysostomus I had problems a while back, on a fresh non-architect install.

aur/ranger-git 1.9.2.333.gfcb01c2c-1 [installed] [143+] [0.37%] [25 Sep 2019]
community/python-pillow 6.2.1-1 [installed]
aur/python-ueberzug-git 18.1.5.a8ac9c3-1 [installed] [4+] [0.85%] [5 Nov 2019]

Is what I have.

I don't know anything about alacritty; that said, I like how I can view images directly from the terminal using kitty.

Ueberzug image previews should also work in tty.

By the way, I also tried alacritty, but it didn't work either. (We now know why, of course - because the problem was in ranger itself.)

I updated now all branches based on ranger-git. We had been using the Arch package. I had not noticed because I was running ranger-git too

4 Likes

Forum kindly sponsored by