No flatpak switch in Pamac Third Party option setting

I installed libpamac-flatpak-plugin, restarted pamac, but the setting for enabling flatpak support is missing.
pamac snap plugin is working and switch is there.

I would suggest that you uninstall Pamac cause it’s not always accurate. In it’s stead I would install and use Bauh to check for updates, but still do the updates from your terminal. I would also install Topgrade and use it to do your updates cause it will do all your updates no matter what protocol was used to install your apps. If you install Bauh you will want to add bauh-tray to autostart. Bauh will handle Flatpak, Snap, Appimage, Web apps, Arch(AUR). I also recommend installing Pacseek for installing indivual apps.

“manually installed the service”???
Just installed the libpamac-flatpak-plugin…
The command line flatpak search is working.

Have you done

sudo pacman -Syu flatpak libpamac-flatpak-plugin

:grey_question: (…and a reboot)
It’s working fine here, tried just for couriosity.

Edit: Picture deleted to save forum storage.

Ah, just saw you are on unstable.
According to our gurus here, this should be the best and most stable branch ever, ha ha ha!
Xfce stable here, with pamac-gtk3 .

Yes, still the same issue.

which desktop? Are you on unstable?

I think it depends on the version your have installed

  • pamac-gtk3 @ 10.6.0
  • pamac-gtk @ 11.6.2 (gtk4)

The libpamac-flatpak-plugin is version 11.6.2 and as such connected to pamac-gtk.

I don’t use flatpak or snap - I think appimage is the closest I get to self-contained apps (Jetbrains Toolbox)

Please check with /etc/pamac.conf - could be that - for unknown reasons - the configuration is not updated correct.

To enable flatpak you should have an entry like


Which of course needs to be un-commented - save the file and reload Pamac

If that doesn’t do it - and it didn’t on my system - then I don’t know how to activate.

He-he :fox_face: I think that depends on member’s use case and skill set. I am one of those who like unstable branch a lot …

But if member insist on using strange packages build using custom scripts - even unstable becomes unstable …

The native method for flatpak is flatpak itself flatpak(1) — Arch manual pages.

man flatpak

I had the same problem & couldn’t figure it out & lost all my flatpaks & screwed my system after an update. So i’m back on Stable version of gnome. I have done all & more than everyone has pointed out so far & nothing worked. The iso from the unstable out of the box is screwed up as well as the update that ruined it is in the update unstable iso aswell. The adventures continue. Something to do with the gtk.

I think you don’t have to manually install this plugin from Terminal…

If you enable Flatpak in the GUI, it triggers the install also.

I also think this is the reason… when @ara remove the # to enable Flatpak, this option will show in the User Interface.

Really strange. If I edit pamac.conf and set


Run pamac again and sync databases the setting in pamac.conf is commented (disabled) again???

I downgraded to stable branch…and Flatpak option is available again!

The reason pamac is disabling flatpak support if manually enabled is probably based in the changes with appstream data 1.0.

libpamac-flatpak-plugin has been removed until libpamac has been updated to work with new appstream API

1 Like

Yes, flatpak in pamac unavailable again after the stable update from today.
Using bauh until the appstream/flatpak/pamac issue is fixed.

…has anybody even tried before talking (and meaning and saluting)? Xfce, stable-branch, pamac-gtk3 (…is what xfce users should choose).

…here was a picture form pamac-gtk3 (stable-branch) with working flatpak…

Edit: I will remove the picture within 24 hours to keep the forum lean.

Yes, flatpak available, Mate, stable-branch, pamac-gtk.
Not available in unstable-branch.

This topic is tagged with unstable so - unless I am mistaken - what has stable branch to do with it?


…I answer quertions

Fixed with libpamac / libpamac-flatpak-plugin 11.6.2+6+ge74fe0e-4.

Error in type 'application/x-core' (in /usr/share/mime/packages/ Error in <match> element: Mask is longer than value.
Error in type 'image/jp2' (in /usr/share/mime/packages/ Error in <match> element: Mask is longer than value.
Error in type 'image/jpx' (in /usr/share/mime/packages/ Error in <match> element: Mask is longer than value.
Error in type 'image/jpm' (in /usr/share/mime/packages/ Error in <match> element: Mask is longer than value.
Error in type 'video/mj2' (in /usr/share/mime/packages/ Error in <match> element: Mask is longer than value.
Error in type 'image/vnd.adobe.photoshop' (in /usr/share/mime/packages/ Error in <match> element: Mask is longer than value.

That’s not related to libpamac. See:

Please copy and paste terminal output using preformatted text instead of uploading screenshots of text.

Each image uploaded to the server makes forum database backups larger. Search engines cannot read screenshots and one cannot copy and paste from them without an OCR program.

Please edit your post accordingly.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.