No effects and animation stutter after Gnome power settings introduction

Hello everybody!

I have some issues with the new power management options introduced to Gnome a while ago and can’t find much about it online so far.
The animations when switching between screens, minimizing or maximizing windows etc. got a bit stuttery and effects like the “burn my windows” extension don’t work at all. It worked all smoothly before and I’ve been using “slimbook battery” before for power management, which worked like a charm.

With the update that introduced the integrated power management options, the problems occured. I decided to wait for a fix in a kernel update, but nothing happened so far.

Is there a way to fix this or at least deactivate the Gnome Shell function and switch back to slimbook battery?

I am using Manjaro Gnome on a Lenovo Ideapad 3, unfortunately with nvidia graphics. I use the proprietary drivers - switching to open drivers didn’t fix the problem.

I am grateful for any suggestions.

Hi @schmox, and welcome!

I don’t have Gnome, and neither do I have a laptop, so don’t have, use or really care about power management.

However, after some googling, I found this page, a reddit answer, that states:

It’s a hard dependence of gnome 41, if you try to install it other programs (bolt, gnome-
calendar, maybe others) that depend on it will be uninstalled.

systemctl stop power-profiles-daemon


systemctl mask power-profiles-daemon

will do the trick. The profiles will disappear from the control center, and you can let TLP or whatever take over the power management.

Hope this helps!

Before you do the above … maybe it would be instructful to check running service;

systemctl | grep -iE 'tlp|power'

( … I think I remember gnomes new power profile thing being weird and creating problems, especially if other power managers are present, such as TLP …)

Thanks for the advice! This is what the terminal shows:

power-profiles-daemon.service                                                          loaded active running   Power Profiles daemon

upower.service                                                                         loaded active running   Daemon for power management

Should I rather uninstall TLP or deactivate the power profiles daemon as suggested in the first answer?

It seems TLP is not running, so my guess probably does not apply.
(which makes sense … the ISO should have been prepared with this in consideration)

Alright, I deactivated the daemon and masked it, but not much changed. I also put slimbook battery in charge of power management again, with no improvement. I now reactivated the daemon to be back to standard.

So this wasn’t the issue, as it seems. But everything was running very fluid after upgrading to Gnome 40, just with the update that introduced the new power management options everything became… kind of… choppy…

So thank you very much for the help so far. Does somebody have another idea of what’s going on?

1 Like

Did you reboot after? Your CPU may have still been in the low power state.

1 Like

Yes, I rebooted before reversing the changes. No Effect.
Well, the system works basically fine, so it’s not a big issue, it is just… less fun using the system, especially since it worked flawlessly before.

Are there any diagnostics I could run that might enable somebody here to help me find out what causes this behaviour?