No desktop after upgrade

I upgraded yesterday and now I can log in but no desktop. I have access to a terminal ( disappears sometimes), access to my browser is ok but no desktop at all. Very annoying and have no idea how to fix this----step by step if possible. KDE plasma. kernel 5.12.2-1. Thanks for any help

Hi you can downgrade your kernel if installed. This won’t fix your bug on kernel 5.12 but you should have a desktop environment. I use also KDE plasma with the 5.10 kernel it works well, mostly.

Please send output of plasmashell

how do I do that? (sorry but pretty useless)

plasmashell: symbol lookup error: /usr/lib/ undefined symbol: _ZN14KWindowEffects11slideWindowEP7QWindowNS_17SlideFromLocationEi


please backup /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
and delete /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
if not worked restore backup of /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
to do this type :
cp /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
sudo rm -rf /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami

if not work please use this :
sudo cp kirigami /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami

is thatt step by step? sorry but am a real beginner

cp /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
cp: opérande de fichier cible manquant après ‘/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami’
Saisissez « cp --help » pour plus d’informations.
[ms@ms-nl4050cu ~]$ sudo rm -rf /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
[sudo] Mot de passe de ms :
[ms@ms-nl4050cu ~]$ plasmashell
plasmashell: symbol lookup error: /usr/lib/ undefined symbol: _ZN14KWindowEffects11slideWindowEP7QWindowNS_17SlideFromLocationEi
[ms@ms-nl4050cu ~]$ sudo cp kirigami /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
cp: impossible d’évaluer ‘kirigami’: Aucun fichier ou dossier de ce type

you entered :cp /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
but you most enter sudo cp /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami

sudo need to have root access

sudo cp /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami
[sudo] password for ms:
cp: missing destination file operand after ‘/usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/kirigami’
Try ‘cp --help’ for more information.

I’m lost

Check if you have any -git packages of KDE installed. Replace them with the regular ones. A lot of posts regarding that was already posted after the update. Also check if you have plasma-desktop-primex installed and replace it with the regular one.

OK, thanks but I don’t know the commands

This command will reveal what -git packages are installed on your system:
pamac search -iq git | grep "-git"
then, once you have that list, you install the non git version of them.
Example if you have kio-git installed, you install kio … and so on.

Thank you very much. Great help! :slight_smile:

I have a similar problem, when I tried this, it gives me this, please help:

$ pamac search -iq git | grep “-git”
grep: invalid option – ‘g’
Usage: grep [OPTION]… PATTERNS [FILE]…
Try ‘grep --help’ for more information.

To give more info, here’s my system:

System: Host: AR-Manjaro Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5 Distro: Manjaro Linux

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 39 bits physical, 48 bits virtual
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 60
Model name: Intel(R) Core™ i5-4440 CPU @ 3.10GHz
Stepping: 3
CPU MHz: 3248.670
CPU max MHz: 3300.0000
CPU min MHz: 800.0000
BogoMIPS: 6187.15
Virtualization: VT-x
L1d cache: 128 KiB
L1i cache: 128 KiB
L2 cache: 1 MiB
L3 cache: 6 MiB
NUMA node0 CPU(s): 0-3
Vulnerability Itlb multihit: KVM: Mitigation: VMX disabled
Vulnerability L1tf: Mitigation; PTE Inversion; VMX conditional cache flushes, SMT disabled
Vulnerability Mds: Mitigation; Clear CPU buffers; SMT disabled
Vulnerability Meltdown: Mitigation; PTI
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2: Mitigation; Full generic retpoline, IBPB conditional, IBRS_FW, STIBP disabled, RSB filling
Vulnerability Srbds: Mitigation; Microcode
Vulnerability Tsx async abort: Not affected
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfm
perf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe p
opcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault invpcid_single pti ssbd ibrs ibpb stibp t
pr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida
arat pln pts md_clear flush_l1d

I got the same response as you, standWithHK. I hope Manjaro fixes this problem with the next upgrade but I am wary of upgrades now. It all worked so well before

1 Like

still no solution. I tried to follow other threads but without result