No boot after update (14 feb. 2020)

Hi, I just updated my system and can't boot anymore. It goes to the grub selector with the two boot option (windows on another harddrive). it goes for manjaro and it gives a black screen.

I'm searching for answers but any idea would be appreciated. I still have the grub command tool it seems.

thanks !

Might be related to this issue

also something i mentioned here

Downgrade the packages from a runlevel 3 boot/TTY, and then try again to normally boot into system.

probably the same issue. I should have never restarted the thing lol

what is it ? how do I downgrade without acess to pacman ?
I'm on the live CD right now trying to find a way to the solution.
thanks !

Boot from you system, but on GRUB menu pres e to edit it and replace quiet with 3 then press F10 to save and continue booting. And from TTY, as your user, run:
sudo pacman-mirrors -f5 && sudo pacman -Syyuu
hopefully those packages got downgraded on the stable branch.
If that doesn't work, install downgrade package and use
sudo downgrade <package>
and replace with the ones i mentioned in my second link, and install them from local.
Hope this helps!

I can accès the édit page but il freezer Before i can reach the quiet argument. How should i browse through the édit. Thanks

I have the same problem. I did your command, but pacman tells me, there is nothing to do.

What is the packagename, that I have to downgrade with "sudo downgrade <package>?


I manage to have Manjaro back.

the package name is "mesa" , I downgraded it to the 13.3.3-1 as mention by bogdancovaciu (the second option in the downgrade tool), I also had the pacman message but I think it's normal (I don't use pacman in a terminal very often).

Well, I spent 1h with the livecd whereas I just needed to do alt+ctrl+F4 on the black screen (which I totally forgot) to get the terminal and do the manipulations. Manjaro's back !


Seems upstream created some regression in that Mesa release. This got now also reported on Arch. We removed our overlay. Please do a downgrade via:

sudo pacman -Syyuu

1 Like

Here is the solution for my problem:

thanks to @philm

Forum kindly sponsored by