No bluetooth devices found after sleep, i have a few that should be listed?

After the last stable update the bluetooth dropdown box on KDE will not remember its list of devices when woken from sleep. I am forced to go into the bluetooth settings where they are listed and connect from there. It always worked before. I have removed all my devises and re-added them but it still the same.

ksnip_20220125-054159

System:
Host: greg-inspiron5767 Kernel: 5.10.93-1-MANJARO x86_64 bits: 64
Desktop: KDE Plasma 5.23.5 Distro: Manjaro Linux
Machine:
Type: Laptop System: Dell product: Inspiron 5767 v: N/A
serial:
Mobo: Dell model: 03XWWJ v: A00 serial:
UEFI-[Legacy]: Dell v: 1.4.1 date: 12/24/2020
Network:
Device-1: Intel Wireless 3165 driver: iwlwifi
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
Device-3: Intel Bluetooth wireless interface type: USB driver: btusb

4 Likes

I have captured a log directly after a system sleep/wake. I hope its captured what is causing the problem

❰greg❙~❱✔≻ journalctl -S -10m | grep 'blue'
Jan 25 08:14:29 greg-inspiron5767 kded5[6339]: bluedevil: About to suspend
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: src/profile.c:ext_io_disconnected() Unable to get io data for Hands-Free Voice gateway: getpeername: Transport endpoint
is not connected (107)
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc_xq_453
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc_xq_453
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc_xq_512
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc_xq_512
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc_xq_552
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint unregistered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc_xq_552
Jan 25 08:14:42 greg-inspiron5767 kded5[6339]: bluedevil: About to resume
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:42 greg-inspiron5767 pulseaudio[6432]: Device /org/bluez/hci0/dev_AC_12_2F_6F_22_95 points to a nonexistent adapter /org/bluez/hci0.
Jan 25 08:14:42 greg-inspiron5767 pulseaudio[6432]: Device /org/bluez/hci0/dev_AC_12_2F_5C_CD_C1 points to a nonexistent adapter /org/bluez/hci0.
Jan 25 08:14:42 greg-inspiron5767 plasmashell[6421]: org.kde.plasma.pulseaudio: No object for name "bluez_sink.AC_12_2F_6F_22_95.a2dp_sink"
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc_xq_453
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc_xq_453
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc_xq_512
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc_xq_512
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSink/sbc_xq_552
Jan 25 08:14:42 greg-inspiron5767 bluetoothd[41028]: Endpoint registered: sender=:1.150 path=/MediaEndpoint/A2DPSource/sbc_xq_552
Jan 25 08:14:43 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:43 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
Jan 25 08:14:43 greg-inspiron5767 plasmashell[6421]: file:///usr/share/plasma/plasmoids/org.kde.plasma.bluetooth/contents/ui/logic.js:22: TypeError: Cannot read property 'd
evices' of undefined
❰greg❙~❱✔≻

And this is the log without the grep ‘blue’ for the same sleep/wake cycle

Hi!! :grinning:
I also have the same issue, the applet doesn’t remember its list of devices when woken from sleep. However, despite the list missing, my devices are still working, and I’ve to log out & log in to see them again.

  • Log:
Summary
[albert@RYZTorre ~]$ journalctl -S -10m | grep 'blue'
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc_xq_453
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc_xq_453
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc_xq_512
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc_xq_512
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc_xq_552
ene 25 15:04:57 RYZTorre bluetoothd[431]: Endpoint unregistered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc_xq_552
ene 25 15:04:57 RYZTorre kded5[825]: bluedevil: About to resume
ene 25 15:05:02 RYZTorre pulseaudio[918]: Device /org/bluez/hci0/dev_F8_33_31_C6_65_12 points to a nonexistent adapter /org/bluez/hci0.
ene 25 15:05:02 RYZTorre pulseaudio[918]: Device /org/bluez/hci0/dev_E6_79_3A_B0_97_5F points to a nonexistent adapter /org/bluez/hci0.
ene 25 15:05:02 RYZTorre pulseaudio[918]: Device /org/bluez/hci0/dev_F4_4E_FD_6D_7A_B2 points to a nonexistent adapter /org/bluez/hci0.
ene 25 15:05:02 RYZTorre pulseaudio[918]: Device /org/bluez/hci0/dev_86_42_46_81_63_7E points to a nonexistent adapter /org/bluez/hci0.
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc_xq_453
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc_xq_453
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc_xq_512
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc_xq_512
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSink/sbc_xq_552
ene 25 15:05:02 RYZTorre bluetoothd[431]: Endpoint registered: sender=:1.66 path=/MediaEndpoint/A2DPSource/sbc_xq_552
ene 25 15:05:13 RYZTorre systemsettings5[1381]: kf.coreaddons: KPluginFactory could not load the plugin "/usr/lib/qt/plugins/kcms/kcm_bluetooth.so"
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/deviceinfo/deviceinfo.c:read_pnpid_cb() Error reading PNP_ID value: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/scanparam/scan.c:refresh_ccc_written_cb() Scan Refresh: notifications not enabled Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:info_read_cb() HID Information read failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:proto_mode_read_cb() Protocol Mode characteristic read failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_map_read_cb() Report Map read failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:external_report_reference_cb() Read External Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_reference_cb() Read Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_reference_cb() Read Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_reference_cb() Read Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_reference_cb() Read Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_reference_cb() Read Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:25 RYZTorre bluetoothd[431]: profiles/input/hog-lib.c:report_reference_cb() Read Report Reference descriptor failed: Request attribute has encountered an unlikely error
ene 25 15:05:27 RYZTorre systemsettings5[1381]: file:///usr/share/kpackage/kcms/kcm_bluetooth/contents/ui/Device.qml:62:9: QML FormLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "preferredHeight"
  • Inxi detail:
Summary
[albert@RYZTorre ~]$ inxi -Fazy
System:
  Kernel: 5.16.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=a5f58ac5-c284-4433-bdc9-6d4def373958 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B450M S2H serial: <superuser required>
    UEFI: American Megatrends LLC. v: F62d date: 10/13/2021
CPU:
  Info: model: AMD Ryzen 3 1200 bits: 64 type: MCP arch: Zen family: 0x17 (23)
    model-id: 1 stepping: 1 microcode: 0x8001138
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1634 high: 2068 min/max: 1550/3100 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1376 2: 2068
    3: 1548 4: 1547 bogomips: 24760
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
    vendor: Sapphire Limited driver: amdgpu v: kernel bus-ID: 09:00.0
    chip-ID: 1002:699f class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: DisplayPort-0 res: 1920x1080 dpi: 96
    size: 509x286mm (20.0x11.3") diag: 584mm (23")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
    vendor: Sapphire Limited driver: snd_hda_intel v: kernel bus-ID: 09:00.1
    chip-ID: 1002:aae0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 0b:00.3 chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: no
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 06:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 08:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:2
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 1.02 TiB used: 380.38 GiB (36.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0002 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 023 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST500LM030-1RK17D
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: RSM7 scheme: GPT
Partition:
  ID-1: / raw-size: 465.46 GiB size: 457.16 GiB (98.22%)
    used: 126.84 GiB (27.7%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: 16.8 C mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 2098
Info:
  Processes: 272 Uptime: 20m wakeups: 1 Memory: 15.61 GiB
  used: 2.47 GiB (15.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1463 lib: 402 flatpak: 0
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

Regards

@acutbal you can save yourself needing to logoff & logon by restarting the service with a console command

sudo systemctl restart bluetooth

Its not an answer unfortunately, just a tiny time save for now :frowning:

3 Likes

Yes, you are right, it’s a workaround until a fix is released.
Thanks!! :grinning:

Ah, that was disappointing :frowning: I thought the notification i just received was going to be someone who could help, o well the more with the same problem the merrier.

Can we assume pariahkite is using KDE desktop too?

I have the same issue since latest stable update, KDE, 5.15.16-1-MANJARO. What’s really weird is that my Logitech mouse will reconnect just fine via bluetooth but my headset (A2DP) will not until I restart the service.

1 Like

So which actual package is at fault here? Who are we supposed to contact, is there a git bug reporting or something?

[2022-01-23T14:57:06+0000] [ALPM] upgraded bluez (5.62-1 -> 5.63-1)
[2022-01-23T14:57:06+0000] [ALPM] upgraded bluez-qt (5.89.0-1 -> 5.90.0-1)
[2022-01-23T14:57:06+0000] [ALPM] upgraded bluedevil (1:5.23.4-1 -> 1:5.23.5-1)
[2022-01-23T14:57:06+0000] [ALPM] upgraded bluez-libs (5.62-1 -> 5.63-1)
[2022-01-23T14:57:06+0000] [ALPM] upgraded bluez-utils (5.62-1 -> 5.63-1)

I have downgraded my bluez package back to previous version bluez-5.62-1-x86_64.pkg.tar.zst

sudo pacman -U /var/cache/pacman/pkg/bluez-5.62-1-x86_64.pkg.tar.zst

Then make it an ignored package so it wont update again until they have patched/fixed it (by removing this entry).

edit with your personal editor:-  /etc/pacman.conf
find # IgnorePkg =
add the packag to ignore, bluez in this case

# IgnorePkg = bluez

Save file /etc/pacman.conf

You could also use the “downgrade” app to do both the downgrade and the ignore package, you just need to install it with sudo pacman -S downgrade

More info if required Downgrading packages - Manjaro

Iv checked this downgrade and its working for me :slight_smile:

3 Likes

Yup. Here’s the output from inxi --admin --verbosity=7 --filter --width:

System:
  Kernel: 5.16.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=2c6dd6cd-0652-407b-a5ad-bca998619889 rw quiet apparmor=1
    security=apparmor resume=UUID=9bf47d72-3a49-42a5-b9b2-f3d0841ee34e
    udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 20JES01U2C v: ThinkPad X1 Yoga 2nd
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: LENOVO model: 20JES01U2C v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N1NET54W (1.41 )
    date: 08/17/2021
Battery:
  ID-1: BAT0 charge: 12.2 Wh (25.3%) condition: 48.2/56.0 Wh (86.1%)
    volts: 16.4 min: 15.3 model: SMP 01AV441 type: Li-poly serial: <filter>
    status: Charging cycles: 432
Memory:
  RAM: total: 15.37 GiB used: 3.16 GiB (20.6%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i7-7600U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 835 high: 843 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 834 2: 822 3: 843 4: 842
    bogomips: 23209
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
    hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm
    lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
    pts rdrand rdseed rdtscp rep_good sdbg sep sgx smap smep smx ss ssbd sse
    sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-8:3 chip-ID: 04f2:b5ce class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
    s-diag: 777mm (30.6")
  Monitor-1: eDP-1 res: 2560x1440 hz: 60 dpi: 210
    size: 310x175mm (12.2x6.9") diag: 356mm (14")
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.4
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d7 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 04:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:2 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 7 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 953.87 GiB used: 58.39 GiB (6.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD9SN8W-1T00-1006
    size: 953.87 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4006 scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 936.65 GiB size: 920.87 GiB (98.32%)
    used: 58.39 GiB (6.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 2c6dd6cd-0652-407b-a5ad-bca998619889
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: D685-454B
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.92 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: 9bf47d72-3a49-42a5-b9b2-f3d0841ee34e
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2b class-ID: e001
  Device-2: 1-8:3 info: Chicony Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b5ce class-ID: 0e02
  Device-3: 1-9:10 info: Validity Sensors type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 138a:0097 class-ID: ff00 serial: <filter>
  Device-4: 1-10:5 info: Wacom Pen and multitouch sensor type: HID
    driver: usbhid,wacom interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 400mA
    chip-ID: 056a:5087 class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 43.0 C pch: 41.5 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 197 Uptime: 2d 17h 58m wakeups: 11 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1378
  pacman: 1364 lib: 368 flatpak: 7 snap: 7 Shell: Zsh v: 5.8 default: Bash
  v: 5.1.16 running-in: yakuake inxi: 3.3.12

It’s related to this bug:

https://bugs.kde.org/show_bug.cgi?id=449178

The KDE devs are working to find a fix.

4 Likes

This did the trick, thank you for that! :wink: :+1:

Well, I did recently upgrade my kernel to 5.15 to see if that might help as it has done some people with similar problems and yes it did actually allow me to upgrade bluez, and it worked, right up until the stable update just yesterday, now it stopped working again.

I’ve downgraded bluez again :frowning: It’s a bit weird though as the update from yesterday did not touch bluez or anything that I can see might be related, o well whatever, I shall keep waiting.

Maybe 5.16 or 5.17 could be worth a try but meh, maybe later