No Bluetooth Adapters have been found after reboot

So after having zero issues with manjaro, bluetooth decided to take a dump after a reboot. I’m not entirely sure what happened and have checked multiple other posts and tried to follow along with others suggested to find the problem to no avail. Any help would be nice to figure out what happened.
Thank You

If you didn’t try already, see with another kernel. More information would be required to provide you with some help, but you can also try to identify the issue trough this wiki page, based on the error you get:

1 Like

Thank you for replying. My problem initially started on on kernel 5.6, then I upgraded to 5.7 and now I’m on 5.8 and the problem has persisted the entire time. I have tried going through the troubleshooting link you provided but I’m not having much luck.
When I use hcitool dev it returns nothing
When I use lsmod | grep blue I get -
bluetooth 720896 0
ecdh_generic 16384 1 bluetooth
rfkill 28672 8 asus_wmi,bluetooth,cfg80211
crc16 16384 2 bluetooth,ext4
when I use rfkill list I get -
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

And lastly here’s my system

System: Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.4 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-I GAMING v: Rev 1.xx serial: UEFI: American Megatrends
v: 2801 date: 09/18/2019
Battery: Device-1: sony_controller_battery_a4:ae:11:8a:0d:69 model: N/A charge: N/A status: Full
CPU: Topology: 6-Core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 96032
Speed: 3999 MHz min/max: 2200/4000 MHz Core speeds (MHz): 1: 3996 2: 3999 3: 4000 4: 3997 5: 4001 6: 4019 7: 3999
8: 4001 9: 4000 10: 3999 11: 4018 12: 3998
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 09:00.0
Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting,radeon resolution:
1: 3440x1440~144Hz 2: 1920x1080~60Hz
OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.38.0 5.8.1-3-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.5
direct render: Yes
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 09:00.1
Device-2: Thesycon System & Consulting SMSL SU8 USB2.0 type: USB driver: snd-usb-audio bus ID: 3-3:4
Device-3: Sony DualShock 4 [CUH-ZCT2x] type: USB driver: snd-usb-audio,sony,usbhid bus ID: 3-2.2:6
Sound Server: ALSA v: k5.8.1-3-MANJARO
Network: Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k port: d000 bus ID: 04:00.0
IF: enp4s0 state: down mac:
Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK driver: rtw_8822be v: N/A port: c000
bus ID: 05:00.0
IF: wlp5s0 state: up mac:
Drives: Local Storage: total: 953.87 GiB used: 605.54 GiB (63.5%)
ID-1: /dev/nvme0n1 vendor: HP model: SSD EX920 1TB size: 953.87 GiB
Partition: ID-1: / size: 937.60 GiB used: 605.54 GiB (64.6%) fs: ext4 dev: /dev/dm-0
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 51.4 C mobo: N/A gpu: amdgpu temp: 62 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info: Processes: 295 Uptime: 31m Memory: 15.63 GiB used: 2.49 GiB (15.9%) Init: systemd Compilers: gcc: 10.1.0
Packages: 1309 Shell: Bash v: 5.0.18 inxi: 3.1.05

I’m rather at a loss at this point, I went from using my ps4 controller one minute and the next second blue tooth just disappeared from the system.

So I decided to check if the problem continued on some other live distros and to my dismay the problem was present across the different distros. This lead me to searching for problems with my specific motherboard and the chip and found most people had success doing a cmos reset. So here I am ten minutes later with bluetooth working again after a cmos reset, rather annoying but glad it’s working again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.