No backlight control on Lenovo Legion Y540-15IRH

Hello community,

I just installed the lastest Manjaro KDE on my new Lenovo Legion Y540-15IRH laptop, and backlight control won't work.
Output of inxi -Fx:

System:    Host: laptop Kernel: 5.4.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81SX v: Legion Y540-15IRH serial: <root required> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <root required> UEFI: LENOVO v: BHCN33WW date: 10/10/2019 
Battery:   ID-1: BAT0 charge: 27.4 Wh condition: 57.1/57.0 Wh (100%) model: SMP L17M3PG2 status: Charging 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse charge: 55% (should be ignored) status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 3937 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 3049 2: 3216 3: 2994 4: 2965 5: 3000 6: 3017 7: 2951 
           8: 2997 9: 2958 10: 3152 11: 2748 12: 2808 
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Lenovo driver: nvidia v: 440.36 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.6 driver: nvidia resolution: 1920x1080~144Hz 
           OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.36 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.4.2-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3 
           IF: wlp0s20f3 state: up mac: c0:b8:83:c1:67:4f 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 07:00.0 
           IF: enp7s0 state: down mac: f8:75:a4:45:ec:9f 
Drives:    Local Storage: total: 476.94 GiB used: 16.07 GiB (3.4%) 
           ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA512TCK size: 476.94 GiB 
Partition: ID-1: / size: 198.13 GiB used: 16.05 GiB (8.1%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A gpu: nvidia temp: 44 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 287 Uptime: 5m Memory: 15.56 GiB used: 1.74 GiB (11.2%) Init: systemd Compilers: gcc: 9.2.0 Shell: bash 
           v: 5.0.11 inxi: 3.0.37

I read through the backlight article on the Arch wiki, and tried the following:

  • setting backlight level manually outputting to /sys/class/backlight/acpi_video0/brightness
  • using kernel parameters acpi_backlight={none,vendor,native,video}
  • using xorg-xbacklight
  • installing the linux54-nvidiabl package

So far, none of this worked ... And I can't adjust backlight on my screen thus leading to very poor battery life.
I believe I'm using the latest Nvidia drivers.

If anyone has an idea I'd be glad to try it :slight_smile:

What is the output of:

ls /sys/class/backlight/

and if it contains nvidia_0, do a:

cat /sys/class/backlight/nvidia_0/max_brightness

and then in the following command use 1/4 (25%) of the maximum value)

echo 25 | sudo tee /sys/class/backlight/nvidia_0/actual_brightness
1 Like

Output of
ls /sys/class/backlight
is:
acpi_video0

max_brightness is 100, and I can't write to actual_brightness as it's read-only, only to brightness. I tried writing to brightness but it didn't change anything.

Sorry, then you'll need someone smarter than me...

:sob:

I also encountered this problem when upgrading the graphics card driver and kernel once, do you have any suggestions?

I unfortunately still haven't found a solution to this problem :frowning:

I have solved this problem, used hybrid-nvidia-intel-440x prime with linux55 kernel

Forum kindly sponsored by