No available Wi-Fi Network Detected

Hi, I’m newbie with Linux in general but my Wifi is not detecting any network. In Live it was working but after install it’s not detecting. Tried and read several forum posts but could not find solution.

Here is my system info:

System: Host: pavels-workpc Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.4 Distro: Manjaro Linux
Machine: Type: Laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH serial: <superuser/root required>
Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <superuser/root required> UEFI: LENOVO v: 8JCN48WW
date: 11/02/2018
Battery: ID-1: BAT0 charge: 40.7 Wh condition: 40.7/52.5 Wh (77%)
CPU: Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP L2 cache: 8192 KiB
Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics: Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 450.66
Device-3: Lite-On Integrated Camera type: USB driver: uvcvideo
Display: x11 server: X .Org 1.20.8 driver: modesetting,nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66
Audio: Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.7.17-2-MANJARO
Network: Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: rtw_8822be
IF: wlp7s0 state: down mac: d2:90:48:cf:12:58
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
IF: enp8s0 state: down mac: 8c:16:45:e3:59:c3
IF-ID-1: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac: d2:74:27:73:21:13
Drives: Local Storage: total: 2.05 TiB used: 28.08 GiB (1.3%)
ID-1: /dev/nvme0n1 vendor: A-Data model: SX6000PNP size: 238.47 GiB
ID-2: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB
Partition: ID-1: / size: 47.87 GiB used: 28.06 GiB (58.6%) fs: ext4 dev: /dev/nvme0n1p4
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 60.0 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A
Info: Processes: 245 Uptime: 5m Memory: 7.65 GiB used: 1.59 GiB (20.7%) Shell: Bash inxi: 3.1.05

I really would appreciate some help! Thank you!

I had a similar issue with my RTL8821CE network card.

You are going to have to go to the AUR and search for your network card: RTL8822BE

Then download the package that relates to your card and build/install it.

You will probably have to physically connect your computer to a LAN cable to get it to download.

Already tried that - no luck… I was using this GitHub - lwfinger/rtw88

Does it come up with any errors, or does it just go through like there is nothing wrong and then not work?

It just goes like nothing would be wrong

Try the tomaspinho / rtl8821ce package

Could you help me and say which commands to type in? I’am huge noob rn with Linux… Sorry…

no problem. Make sure you are in your desktop directory in terminal. Then, download dkms by using the Manjaro package manager.

After that, run the following commands:

git clone
cd rtl8821ce-dkms-git
makepkg -sic

Sadly still no luck… Honestly no idea what could be wrong. Have tried different ways and still nothing…

Have you restarted your computer since installing the first one you tried?

Yes, after every try from before have rebooted the system

Sorry for the barrage of questions.

Did you have dkms installed when you installed the first one?

It should be from previous attempts. How can I check if it is?

No worries for questions - rather sorry for my stupidity to not fix it myself and use your time xD

You’re not stupid.

just go to the “start menu”

type “add”

click “add/removed software”

search for dkms

It should have a “Remove” option if it is installed.

Yeah it’s installed

I’m going to do a little more research and if I find anything I will let you know.

Since we installed the one you said to install shouldnt it said different driver now? Not rtw_8822be?

This is info what I got right now:

Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: rtw_8822be
IF: wlp7s0 state: down mac: 96:76:a8:1d:37:bf

In any case huge thanks for helping! I appreciate it alot!

I found a link but the forum isn’t letting me post it again.

Basically, this specific card has two antenna and can old use one. You have to use commands to tell it which one to use.

I will try and copy/paste the required commands.

  1. Some HP laptops with the Realtek WiFi chipset card RTL8723BE have just one antenna on that card designed for two (stingy HP, anyone?). This has caused many problems for Linux users, as the default antenna is usually the missing one…

But thanks to Larry Finger and the good people at Realtek you can do some testing with a module parameter that allows for antenna selection. As follows:

a. Launch a terminal window.

b. First unload the currently active module with this command

sudo modprobe -r rtw_8723be

Press Enter. Type your password when prompted. In Ubuntu this remains entirely invisible, not even dots will show when you type it, that’s normal. In Mint this has changed: you’ll see asterisks when you type. Press Enter again.

c. Then reload it with the instruction to use antenna number 2, with this command:

sudo modprobe rtw_8723be ant_sel=2

Press Enter.

d. Then check the signal strength with this command:

iwlist scan | egrep -i ‘ssid|quality’

Press Enter.

e. Then test the the other antenna (number 1), to find out which one has a stronger signal. For this, execute the following three commands:

sudo modprobe -r rtw_8723be

sudo modprobe rtw_8723be ant_sel=1

iwlist scan | egrep -i ‘ssid|quality’

f. If ant_sel=2 gives the best signal (which is usually the case), do this

echo “options rtw_8723be ant_sel=2” | sudo tee -a /etc/modprobe.d/rtw_8723be.conf

Reboot your computer.

*If ant_sel=1 gives the best signal (unusual, but not impossible), do this (this is one line, [use copy/paste]

echo “options rtw_8723be ant_sel=1” | sudo tee -a /etc/modprobe.d/rtw_8723be.conf

Copy and pasted from website

I replace with rtw_8822be correct? Since rtw_8822be is my chip