No audio when Audacity is open

drivers
audio
alsa

#1

Hello,

my main problem is that once I open up audacity all system sound gets muted and in order to have audio again I have to close audacity, change the output to something else, then back again AND close Chrome or Firefox. I’ve tried most of the troubleshooting listed on the arch wiki but nothing helps. This problem consists only when I open up audacity.

Thanks for reading.

Edit: When I open up Ardour it’s the same problem


#2

do you have JACK installed or are you using plain alsa?


#3

Plain alsa…


#4

I have that problem when using audacity with jack, which happens because for some reason audacity decides to mute some channels when I launch it. Simply opening my mixer and unmuting the channels I want fixes it for me.

Another thing that could be happening is that a lot of audio programs automatically fire up a jack server on startup if they can’t detect one running and connect to it, and that messes up programs expecting alsa or pa.


#5

get jack going, also be sure to install all the relevant pulseaudio plugins. finally install either cadence or qjackctl for easier configuration. this will make it so you can use more than one audio app at the same time


#6

Plain alsa can only deal with one sound stream, so if you have Firefox or any other audio source audacity cannot connect.

Audacity with plain alsa is only useful for editing pre-recorded audio files

can use dmix with alsa for multiple audio sources, but in my experience isn’t as good as using pulseaudio.
If don’t want pulseaudio, use JACK and have lots of recording options


#7

I’ve replaced alsa with Jack2, now it’s working but I get Xruns even when the usage is only 2-3%. The device is a USB mixer, periods are set to 3, 48000Hz and buffer size is 256…


#8

Turning buffer size up to 512 or 1024 would reduce x-runs, but increase latency

There are many adjustments needed to a standard Linux installation to make it suitable for use as an audio workstation. try realtimeconfigquickscan (available in AUR) to check the main settings are correct


#9

I only encounter Xruns when opening new windows, or generally operating different programs while recording. Usage meanwhile never hits more than 5%. I’ve tried multiple configurations all aiming for a latency of ~5 ms and so far none of them work to the extent I’d like them to…


#10

x-runs opening new applications are ok, not something you should normally do when recording

If you can monitor audio from the mixer before it goes in to pc and gets delayed then jack latency doesn’t matter. if you can work around latency problems you can use higher settings and record clean with no x-runs

I can get JACK running with few x-runs at 10ms latency using onboard pci card with standard manjaro kernel, not yet fully tested with realtime kernel.

This is something I came across last week that may help you get better performance over USB
http://crimeandtheforcesofevil.com/blog/2016/07/25/so-hey-usb-chipsets-totally-matter/
(adding a usb pci/pcie card with correct chipset to get lower latency)


#11

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.