No audio - ROG G17 G712LV - Fresh Install, Device detected


I just installed Manjaro this morning, after having similar issues with PopOS 20.10.
Pulse and Alsa both show my sound card as present. Nothing is muted, and I have followed pretty much any thread I could find on Google for this issue. I’ve tried changing kernel versions, reinstalling pulse and alsa, and I’m at a loss.
When I play audio via YouTube or do an audio test, I can see the bars bouncing but there is no output via speakers, or headphones.
I feel like I’m playing with Ubuntu circa 2009!

Any help would be greatly appreciated!!!

I just tried pipewire, and no change…and now I don’t have pulse at all. haha Digging myself a hole, it seems.

welcome to the party, many of us. try real time kernel 5.9 - the only solution that worked for me.

See this previous post for an ALSA modprobe patch that should get speakers working,
but it does not have an audio level control in ALSA
Audio doesn't work in internal speaker but it works on Headphones - #14 by nikgnomic

In a later post (#17) there are links to a method for a full working solution but it is not something an inexperienced user could implement easily
If one user can find the audio configuration data from a Windows VM and patch ALSA, the ALSA developers can make a patch for the Linux kernel so that the audio for this model laptop will work

If I had access to a similar laptop I would attempt this, but I have never used a VM before so it might take me a few weeks, and a few litres of coffee, and a lot of inappropriate language!

Well, between the 2 replies, I’m getting closer…

Changing to Kernel 5.9 helped get audio back through headphones, with full volume control.
Changing to the zenbook settings got speaker audio…but now I have ZERO volume control.

I’m honestly surprised that, given the fact that the audio controller in this laptop is a few years old, there’s no decent support for it in alsa!