No audio input for Firefox intermittently, nothing listed in pactl list-sinks


I seem to intermittently not get audio from Firefox, usually when I launch it after my computer has been idle for a while. I usually need to reboot to resolve the issue, simply killing Firefox doesn’t seem to always help, although it does sometimes.

It doesn’t even show up in the audio input, but other system sounds seem to work fine. Nothing from pactl list-sinks.

I’ve already tried reinstalling pipewire and ensuring its activated, and other audio seems to be fine.

Any idea on next steps? It almost seems like it happens if I launch something in the browser that tries to play audio before the audio card is awake.


You could try to run from terminal
amixer --card=0 sset 'Auto-Mute Mode' disabled

You can also do that visually from alsamixer

But you mentioned in the title the input - that would be the microphone, and maybe for that you have to allow it in Firefox Permission settings.
If is the audio output - as a sound from a video on youtube for example, and you are on pipewire, check if the service stops after a while … Also, not sure if you manually switched from pulseaudio to pipewire, but making sure the manjaro-pipewire is installed, would decrease the chances to have some mixed stuff there.

Hey, yeah, already tried checking that auto mute is disabled.

And you’re right, I mean the output from the application that’s empty.

Pipewire is working since it works for other applications, just not seemingly Firefox. I’ve checked that it’s still enabled. a while back, but reinstalled it recently just to be sure