No audio from speakers, bluetooth and audio jack work fine

Just dual booted my new Windows 11 laptop with Manjaro. Bluetooth and wired headphones work just fine, but my speakers are still not working despite trying some of the common fixes suggested on this forum.
I tried with pulseaudio as that was the default when I installed Manjaro, and I installed manjaro-pipewire, but no luck.
The speakers work fine on Windows.

My output for

inxi -Fazy

  Kernel: 5.19.17-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.19-x86_64
    root=UUID=d823ee6c-8538-4188-92a8-8896669c1fa2 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 42.5 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP ZBook Firefly 14 inch G9 Mobile
    Workstation PC v: N/A serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 8ABB v: KBC Version 20.48.00 serial: <superuser required>
    UEFI: HP v: U71 Ver. 01.03.01 date: 09/07/2022
  ID-1: BAT0 charge: 34.5 Wh (68.2%) condition: 50.6/51.3 Wh (98.7%)
    volts: 11.7 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: discharging cycles: 5
  Info: model: 12th Gen Intel Core i7-1255U bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x421
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2197 high: 3419 min/max: 400/3429:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 745 2: 606 3: 2600 4: 2600
    5: 2600 6: 2600 7: 796 8: 3419 9: 2600 10: 2600 11: 2600 12: 2600
    bogomips: 62688
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-UP3 GT2 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:4628 class-ID: 0300
  Device-2: Chicony HP 5MP Camera type: USB driver: uvcvideo bus-ID: 3-1:2
    chip-ID: 04f2:b738 class-ID: fe01 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 22.1.4
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x5a99 built: 2021 res: 1920x1200
    dpi: 162 gamma: 1.2 size: 301x188mm (11.85x7.4") diag: 355mm (14")
    ratio: 16:10 modes: 1920x1200
  API: OpenGL v: 4.6 Mesa 22.2.1 renderer: Mesa Intel Graphics (ADL GT2)
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Sound API: ALSA v: k5.19.17-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 953.87 GiB used: 14.37 GiB (1.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
    SN810 SDCPNRY-1T00-1006 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS2 temp: 35.9 C scheme: GPT
  ID-1: / raw-size: 781.25 GiB size: 767.92 GiB (98.29%) used: 14.2 GiB (1.8%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 169.8 MiB (66.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 325 Uptime: 31m wakeups: 2708 Memory: 15.27 GiB
  used: 3.35 GiB (22.0%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1242 libs: 306 tools: gnome-software,pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.23

pactl list cards
Card #39
	Name: alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic
	Driver: alsa
	Owner Module: n/a
		device.enum.api = "udev"
		device.api = "alsa"
		media.class = "Audio/Device"
		api.alsa.path = "hw:0"
		api.alsa.card = "0" = "sof-hda-dsp"
		api.alsa.card.longname = "HP-HPZBookFirefly14inchG9MobileWorkstationPC--8ABB"
		device.plugged.usec = "9625052"
		device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
		sysfs.path = "/sys/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
		device.bus = "pci"
		device.subsystem = "sound" = "0x8086" = "Intel Corporation" = "0x51c8" = "Alder Lake PCH-P High Definition Audio Controller" = "alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic"
		device.description = "Alder Lake PCH-P High Definition Audio Controller"
		device.nick = "sof-hda-dsp"
		device.icon_name = "audio-card-pci"
		api.alsa.use-acp = "true" = "false" = "false"
		api.dbus.ReserveDevice1 = "Audio0" = "14" = "31" = "39"
		object.serial = "39"
		object.path = "alsa:pcm:0"
		alsa.card = "0"
		alsa.card_name = "sof-hda-dsp"
		alsa.long_card_name = "HP-HPZBookFirefly14inchG9MobileWorkstationPC--8ABB"
		alsa.driver_name = "snd_soc_skl_hda_dsp"
		device.string = "0"
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
		HiFi: Play HiFi quality Music (sinks: 4, sources: 2, priority: 8000, available: yes)
	Active Profile: HiFi
		[Out] HDMI3: HDMI / DisplayPort 3 Output (type: HDMI, priority: 700, latency offset: 0 usec, availability group: HDMI/DP,pcm=5, not available)
				port.type = "hdmi"
				port.availability-group = "HDMI/DP,pcm=5"
				card.profile.port = "0"
			Part of profile(s): HiFi
		[Out] HDMI2: HDMI / DisplayPort 2 Output (type: HDMI, priority: 600, latency offset: 0 usec, availability group: HDMI/DP,pcm=4, not available)
				port.type = "hdmi"
				port.availability-group = "HDMI/DP,pcm=4"
				card.profile.port = "1"
			Part of profile(s): HiFi
		[Out] HDMI1: HDMI / DisplayPort 1 Output (type: HDMI, priority: 500, latency offset: 0 usec, availability group: HDMI/DP,pcm=3, not available)
				port.type = "hdmi"
				port.availability-group = "HDMI/DP,pcm=3"
				card.profile.port = "2"
			Part of profile(s): HiFi
		**[Out] Speaker: Speaker (type: Speaker, priority: 100, latency offset: 0 usec, availability unknown)**
				port.type = "speaker"
				card.profile.port = "3"
			Part of profile(s): HiFi
		[Out] Headphones: Headphones (type: Headphones, priority: 200, latency offset: 0 usec, availability group: Headphone, not available)
				port.type = "headphones"
				port.availability-group = "Headphone"
				card.profile.port = "4"
			Part of profile(s): HiFi
		[In] Mic2: Headphones Stereo Microphone (type: Mic, priority: 200, latency offset: 0 usec, availability group: Mic, not available)
				port.type = "mic"
				port.availability-group = "Mic"
				card.profile.port = "5"
			Part of profile(s): HiFi
		[In] Mic1: Digital Microphone (type: Mic, priority: 100, latency offset: 0 usec, availability unknown)
				port.type = "mic"
				card.profile.port = "6"
			Part of profile(s): HiFi

Thanks for any help that people provide, this forum is very much appreciated

That kernel is EOL = End Of Life
Either switch to LTS one, or a actively supported one.

Do you have pipewire-alsa installed? How about sof-firmware?
Check in alsamixer what card you are using and tweak it.

A quick search seems to imply you want kernel 6.0.2 or higher: [PATCH 6.0 09/34] ALSA: hda/realtek: Add quirk for HP Zbook Firefly 14 G9 model - Greg Kroah-Hartman

Currently 6.0.6-1 is available from Manjaro Settings Manager → Kernel which I’d try; quite possibly things start to magically work.

Had somewhat similar issues with a USB sound card “Aureon Dual USB” something. Whenever I switched to this for audio output, most of my applications would stop producing sound and also halt playback. Playback immediately resumed when I switched back to the built-in audio on my laptop.

This thread hinted at the pipewire, so I installed manjaro-pipewire package and restarted (by conflicts that removed some Pulseaudio stuff). Now the sound seems to work fine again, so thanks a lot! :slight_smile:

I should say I am hugely confused by all of this pulseaudio/alsa/pipewire/whatnot, so it is very possible (even likely) that my issues were caused due to me installing a bad combo of mismatching packages.

Wow thanks that worked like a charm!

Although my internal mic still doesn’t work, trying to debug that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.