Nightcolor does not auto start

For some reason while using KDE nightcolor option does not auto-start. If ienable it manually sometimes it will flicker and then work. I had once redshift installed and it might have messed some config I really don´t know.

Relevant info:

inxi -Fxz 
  Kernel: 5.10.30-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: KDE Plasma 5.21.4 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.80 date: 12/25/2019 
  Info: 6-Core model: Intel Core i5-9600K bits: 64 type: MCP 
  arch: Kaby Lake note: check rev: C cache: L2: 9 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44398 
  Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 
  2: 800 3: 800 4: 800 5: 800 6: 800 
  Device-1: NVIDIA vendor: driver: nvidia v: 460.67 
  bus-ID: 01:00.0 
  Device-2: Logitech Logitech Webcam C925e type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 1-1.2:8 
  Display: x11 server: X.Org 1.20.11 driver: loaded: nvidia 
  resolution: 1920x1080 
  OpenGL: renderer: GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
  Device-2: NVIDIA vendor: driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 
  Device-3: Logitech Logitech Webcam C925e type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 1-1.2:8 
  Sound Server-1: ALSA v: k5.10.30-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.17 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.25 running: no 
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI 
  driver: e1000e v: kernel port: efa0 bus-ID: 00:1f.6 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: br-232fd21ea23b state: down mac: <filter> 
  IF-ID-2: br-5d01cbb2628b state: down mac: <filter> 
  IF-ID-3: docker0 state: down mac: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 
  type: USB driver: btusb v: 0.8 bus-ID: 1-1.3:7 
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
  Local Storage: total: 1.33 TiB used: 222.26 GiB (16.3%) 
  ID-1: /dev/sda vendor: A-Data model: SU630 size: 447.13 GiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 EVO 500GB 
  size: 465.76 GiB 
  ID-3: /dev/sdc vendor: Kingston model: SA400S37480G size: 447.13 GiB 
  ID-1: / size: 290.65 GiB used: 214.35 GiB (73.7%) fs: ext4 
  dev: /dev/sdc1 
  ID-2: /boot/efi size: 96 MiB used: 35.3 MiB (36.7%) fs: vfat 
  dev: /dev/sdb2 
  ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) 
  file: /swapfile 
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: nvidia temp: 51 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 251 Uptime: 17m Memory: 15.57 GiB used: 5.78 GiB (37.1%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1697 Shell: Bash 
  v: 5.1.0 inxi: 3.3.04

Check if the night color is set to “Always enabled” on KDE notifications > Configure System Tray > Entries > System Services > Night Color. That will always show that thing on tray, after that, right click on that icon, Configure Night Color, check the radio button “Activate Night Color”. After that, Click “Activation Time” and select the time you’d want. Just to check that it’s working, select “Always On”.