Night Light stays turned on in gdm even after turning it off in desktop

The title says it all. I found the other thread where the solution was to do the following command

“sudo -u gdm dbus-launch --exit-with-session gsettings set org.gnome.settings-daemon.plugins.color night-light-enabled false”

Whether or not this is an efficient or appropriate fix still is beyond me.