Night colour not working

New laptop, fresh Manjaro install. Night colour doesn’t work on the laptop display or on the two connected monitors (or any configuration of said displays).

In journalctl, when I toggle the system tray lightbulb to on, the following messages are printed:

Aug 17 19:21:27 dexter-thinkpad kded5[785]: kf.coreaddons: "Could not load plugin from /usr/lib/qt/plugins/plasma/geolocationprovider/ Cannot load library /usr/lib/qt/plugins/plasma/geolocationprovider/ ( cannot open shared object file: No such file or directory)"
Aug 17 19:21:27 dexter-thinkpad kded5[785]: Failed to load GeolocationProvider: "/usr/lib/qt/plugins/plasma/geolocationprovider/" "Could not load plugin from /usr/lib/qt/plugins/plasma/geolocationprovider/ Cannot load library /usr/lib/qt/plugins/plasma/geolocationprovider/ ( cannot open shared object file: No such file or directory)"
Aug 17 19:21:27 dexter-thinkpad kded5[785]: "location"

Unexpected, as I’m using the “Always on” setting so I wouldn’t expect it to try and get my location.

inxi -v7azy

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=6678422e-a241-44ac-9a39-a8ab93de1b04 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 21CBCTO1WW v: ThinkPad X1 Carbon Gen 10
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 21CBCTO1WW serial: <superuser required> UEFI: LENOVO
    v: N3AET62W (1.27 ) date: 06/24/2022
  ID-1: BAT0 charge: 45.3 Wh (79.5%) condition: 57.0/57.0 Wh (100.0%)
    volts: 16.7 min: 15.4 model: Sunwoda 5B10W13975 type: Li-poly
    serial: <filter> status: not charging cycles: 6
  RAM: total: 31.06 GiB used: 4.9 GiB (15.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: 12th Gen Intel Core i7-1260P bits: 64 type: MST AMCP
    arch: Alder Lake built: 2021 process: Intel 7 (10nm ESF) family: 6
    model-id: 0x9A (154) stepping: 3 microcode: 0x421
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
    L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 649 high: 862 min/max: 400/3462:3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 502 2: 627 3: 849 4: 685
    5: 764 6: 400 7: 663 8: 862 9: 748 10: 537 11: 583 12: 594 13: 601 14: 480
    15: 805 16: 694 bogomips: 79888
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase
    fsrm fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb
    ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe movdir64b movdiri msr mtrr nonstop_tsc nopl nx
    ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt
    pse pse36 pts rdpid rdrand rdseed rdtscp rep_good sdbg sep serialize
    sha_ni smap smep smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer
    tsc_known_freq umip vaes vme vpclmulqdq waitpkg x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: DP-1,HDMI-A-1,eDP-1 empty: DP-2,DP-3,DP-4 bus-ID: 00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-8:3 chip-ID: 04f2:b751 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 6000x4111 s-dpi: 96 s-size: 1586x1086mm (62.44x42.76")
    s-diag: 1922mm (75.68")
  Monitor-1: DP-1 pos: primary,top-left model: BenQ EL2870U serial: <filter>
    built: 2018 res: 2160x3840 hz: 60 dpi: 161 gamma: 1.2
    size: 341x621mm (13.43x24.45") diag: 708mm (27.9") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: bottom-c model: Samsung U28E590
    serial: <filter> built: 2020 res: 3840x2160 hz: 60 dpi: 160 gamma: 1.2
    size: 608x345mm (23.94x13.58") diag: 699mm (27.5") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  Monitor-3: eDP-1 pos: primary,middle-r model: ChiMei InnoLux 0x1417
    built: 2020 res: 1920x1200 hz: 60 dpi: 162 gamma: 1.2
    size: 301x188mm (11.85x7.4") diag: 355mm (14") ratio: 16:10
    modes: 1920x1200
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.6
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 148.72 GiB (62.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFS256GDE9X081N
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 41730C20 temp: 44.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) used: 148.72 GiB
    (63.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: 6678422e-a241-44ac-9a39-a8ab93de1b04
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: NO_LABEL
    uuid: 6BFE-0BEC
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-6:2 info: Synaptics type: <vendor specific> driver: N/A
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00fc
    class-ID: ff00 serial: <filter>
  Device-2: 3-8:3 info: Chicony Integrated Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b751 class-ID: fe01 serial: <filter>
  Device-3: 3-9:4 info: Sunplus Innovation Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 98mA chip-ID: 1bcf:0005 class-ID: 0301
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 54.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 4983
  Processes: 330 Uptime: 16m wakeups: 3608 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: pacman: 1614 lib: 378 flatpak: 0 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.20

I dont think the “Always on” means always available. You are just instructing it to always be active on boot… Location is needed to decide between daytime and Nighttime.

Hm okay. Either way I already tried setting it to “Custom time” and making sure I was within the parameters to no avail.

try reducing the blue light in gamma settings, to see if you are even able to modify your display settings

Good shout. Tried all the sliders, none of them have any effect after hitting apply.

were there any logs when you modify the gamma settings?

Do you have turned it on in the systay? The light bulb icon should be filled and not outlined.

Nothing at all with journalctl --follow

I do :slight_smile:

and can you change your laptops brightness?

Yep works no problem.

Another note: the laptop’s display is touch screen (I don’t think this is listed in the inxi output). But, as I mentioned previously, the night colour or gamma changes were not applied to the external monitors either so I doubt that makes a difference.

install the 5.18 kernel, reboot, select it in grub, boot with it and see if you can change it

1 Like

Installed 5.18.17-1-MANJARO, rebooted, and it was fixed! Interestingly, when I toggle the light bulb in system tray to on, the same 3 errors pop up in journalctl, so they were seemingly unrelated. Changing the gamma settings also works.

Thanks for your help! Will be sure to get onto the latest kernel when facing future problems…

go to system settings/backround services, and uncheck 'colorcorrect geolocation updater` click on the pause button next to it to stop it, click apply and the 3 error messages should be gone…

1 Like

Nice one, that did the job. Cheers.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.