NFS4 Verbindung mit OMV und systemd-automount

Hallo,

Ich möchte per NFS4 mit meinem Manjaro auf ein OMV4 NAs zugreifen.
Hatte vorher das ganze mittels autofs gemacht und hatte auch schreibzugriff, nun habe ich versucht das ganze per systemd-aoutomount zu handhaben.

# NFS - automounts per systemd für OMV-NAS-i7-4770
192.168.1.2:/ /media/nfs/omv-nas nfs x-systemd.automount,noauto,retry=0,x-systemd.idle-timeout=60,nolock,rw,timeo=2,retrans=1,x-systemd.device-timeout=2,soft,nofail	0	0
[egle@NUC8i7HVK ~]$ showmount -e 192.168.1.2
Export list for 192.168.1.2:
/export/Sonstiges 192.168.1.0/24
/export/Daten     192.168.1.0/24
/export/Media     192.168.1.0/24
/export/Serien    192.168.1.0/24
/export/Musik     192.168.1.0/24
/export           192.168.1.0/24
/export/Filme     192.168.1.0/24
[egle@NUC8i7HVK ~]$ 

Leider bekomme ich per Systemd-automount keine Schreibrechte mehr.

Habe zwar auf dem OMV4 NAs diese Optionen gesetzt:

all_squash,anonuid=0,anongid=0,subtree_check,insecure

Aber leider funktioniert das nicht :frowning:

Hat jemand eine Idee was ich falsch mache?

Moin,

ich hab aktuell kein OMV mehr laufen aber ich hatte das früher so gehändelt und das hat prima funktioniert.

#NFS 
openmedia:/store /home/genista/Store nfs noauto,x-systemd.automount
openmedia:/data /home/genista/Data nfs noauto,x-systemd.automount
openmedia:/vault /home/genista/Vault nfs noauto,x-systemd.automount

Welche Freigaben ich im OMV gesetzt hatte weiß ich allerdings auch nicht mehr, vielleicht hilft es ja trotzdem.

Grüße
Genista

1 Like

Hallo,

danke euch beiden @genista & @tbg

Aber bevor ich da nun Händisch wegen einem Bug System-units schreibe.
benutze ich llieber weiterhin autofs das funktionierte Problemlos :slight_smile:

Translate:
But before I write some manual about a bug system units.
I continue to use autofs this working problem-free :slight_smile:

With autofs i have these option and its worked bug-free…

nfs.autofs

/media/nfs /etc/autofs/auto.nfs --ghost --timeout=40

auto.nfs

# Dreamboxen
DM7080  -fstype=nfs,soft,tcp,retry=0 192.168.1.15:/

# OMV-NAS
OMV-NAS-i7-4770 	-fstype=nfs,soft,tcp,retry=0 192.168.1.2:/

# Qnap-NAS
Qnap-TS119    -fstype=nfs,soft,tcp,retry=0 192.168.1.10:/

# Raspberry-Pi
Raspberry	-fstype=nfs,soft,tcp,retry=0 192.168.1.90:/

Wie gesagt, Serverseitig ist ja alles geich nur wenn ich es auf systemd.automount umstelle gibt es keine Schreibzugriffe :unamused:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark